1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Checking for: mailsrv_conf_init... fail

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by caomhan, Mar 17, 2011.

  1. caomhan

    caomhan Guest

    0
     
    Hi there,

    i have some trouble with receiving mails.
    Postfix cannot read the /var/spool/postfix/plesk/virtual and co. because the got damaged by the "mchk" script.

    If i run the mchk script manually it gives me the following error:
    ==> Checking for: mailsrv_conf_init... fail

    If these files are damaged postfix loggs something like "unknown user in receipient table".
    Postfix can't read these files anymore.

    Is there a way to fix this?

    Thanks,
    caom!
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,576
    Likes Received:
    1,244
    Location:
    Novosibirsk, Russia
  3. caomhan

    caomhan Guest

    0
     
    Hi IgorG,

    thanks for your help.
    It worked fine!

    Best regards,
    caom!
     
  4. optip

    optip Guest

    0
     
    i was so worry before reading this threat but after using this trick solve my problem thanks for sharing a
     
  5. caomhan

    caomhan Guest

    0
     
    I thougt i have to reinstall my server. But i've installed my system 2 days ago...
    All the customer files and emails are in this new system already.
    A reinstall would make me head banging for the weekend ;)

    But this do the trick!
    The system runs fine now. Perfect!

    Now making a snapshot of the whole system.
     
  6. caomhan

    caomhan Guest

    0
     
    Once again...

    Hi there,

    i've checked the mchk script once again.
    Now the same issue.

    This morning:

    - mchk fails
    - switched plesk to qmail (mchk through the installer script worked fine)
    - mchk (started manually) worked fine
    - switched plesk to postfix again (mchk script through the installer worked fine again)
    - mchk script (started manually) worked fine again

    Now this evening 11pm in germany i've checked again with mchk:

    Same issue. Fails at mailsrv_conf_init. virtual.db file and co are damaged and unreadable for postfix. Do you have another solution for me?

    It would be very very nice if we found a solution that really works for the future.

    Did the mchk Script Run automatically or only in plesk Updates or something like that?
    Can i disable the mchk script and remove the execute permission? Before updating plesk i can give the mchk Script execute permissions again. Is this a temporarly Solution?

    Thanks for your help!
    Cheers,
    caom
     
    Last edited by a moderator: Mar 18, 2011
  7. caomhan

    caomhan Guest

    0
     
    Hey again,

    got some informations for you.
    If found the main problem in the whole story...

    I've set "chattr +i" for postfix main.cf and master.cf to prevent plesk from overwriting these files. I've made some own settings in these files wich will get overwritten by plesk.

    This "chattr +i" is the reason why the mchk Script fails and stops (because it cannot write in these two files).

    The problem of the .db files wich get damaged:

    These .db files located in /var/spool/postfix/plesk get touched at the beginning of the mchk script with the first lines. Then mchk checks the main.cf and master.cf (with chattr +i) and fails at this point. The script stops and the .db files will not get written completely, so they are damaged.

    When did mchk run?

    Can you tell me if the mchk script runs automatically in any way?
    Or only on plesk updates?

    I've set chattr +i to the postfix files since i'm using plesk (for 5 month) and never got this "problem" with it. That's why i think that the mchk script never runs automatically. Is that right?

    Before updating plesk i've ever set the postfix file with chattr -i and the update went good. Afer updating i've set chattr +i again.

    The one and only question: Did the mchk script runs automatically at any time (except for updates)?

    Thanks and cheers!
    caom
     
Loading...