1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Combined log problem and missing error_log w/ Plesk 7.5.4 upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by JohnTKelly, Dec 2, 2005.

  1. JohnTKelly

    JohnTKelly Guest

    0
     
    I recently upgraded from Plesk v7.02 to 7.54 on RHEL3. I noticed that my Urchin stats were not displaying hits for all domains on the server.

    Searching these forums it appears that Plesk modified the log format to suit themselves, thereby breaking log programs for everyone else.

    I've added these two lines to the vhost.conf for all domains:

    CustomLog /home/httpd/vhosts/unsafeworld.com/statistics/logs/access_log urchin_utm
    LogFormat "%h %v %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" \"%{Cookie}i\"" urchin_utm

    BUT now all entries to access_log are recorded TWICE for every single hit for a file -- once for plesklog, and once for urchin_utm apparently. This is a tremendous waste of space and system resources, so I'd only like the urchin_utm entry to be recorded. How can I do this?

    PLUS the error_log files are no longer beign generated, even though the below line is ni httpd.include:
    ErrorLog /home/httpd/vhosts/domain.com/statistics/logs/error_log

    Any fix for this? The error log is handing for tracking down a lot of problems, I need to have it.
     
  2. JohnTKelly

    JohnTKelly Guest

    0
     
    ... bump ...

    Also noted that while I can suggest a CustomLog directive for Plesk in vhost.conf (though it ignores completely the LogFormat), it will still continue to write to the normal access_log in addition to the CustomLog file specified.

    If there's a way to disable plesklog (and use my own format/logfile), that woudl also work. Any ideas?
     
  3. JohnTKelly

    JohnTKelly Guest

    0
     
    Got a reply from SWSoft tech support:

    Plesk uses hardcoded log format because it is needed by webalizer.
    If you wish to use own log format, there are two ways to solve the problem.

    1. Create own LogFormat and CustomLog in vhost.conf per domain basis.

    2. Redefine Plesk LogFormat in /etc/httpd/conf/httpd.conf after "Include
    /etc/httpd/conf/httpd.include" line. But in this case webalizer and
    Plesk statistics may not work.
     
Loading...