1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

"Components not installed" - so it thinks

Discussion in 'Plesk for Linux - 8.x and Older' started by WebMonkey, May 1, 2005.

  1. WebMonkey

    WebMonkey Guest

    0
     
    Hello

    I have just spent about 4 days trying to install plesk on my server (Fedora Core 2 if it's important). It hasn't been the nicest 4 days, but I've finally managed to get something up and running....well, sort of

    All the packages are up to date, I even managed to run the updater so I know everything is uptodate....but the Services (apache, etc) are all greyed out, and in the "component info" section, everything is marked as "Component was not installed"...even "psa" which I think is impressive seeing as it's currently running.

    It wasn't the smoothest of installations, I must say, hence the 4 days part. If I knew a way of removing everything to do with plesk and starting again, I would do that, but I've tried the rmp -e thing, but it doesn't like it, and when you force it, it often doesn't like that.

    I found it wasn't creating the packagesmng file (which looks empty for reference) during installation, and I'm sure it was missing some files.

    Does ANYONE have any ideas....

    I would be SO grateful if someone's able to help, I'll even pass over some virtual chocolate for your troubles.

    Many thanks, Paul
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I just love the sarcastic virtual chocolate thing....lol

    1. Have you check in the CP to see if it shows a valid license?

    If license shows valid, then
    2. Try using ART's yum to do updates on both the base packages, then separately, the Plesk 7.5.2

    Do it in 2 separate operations so it'll be easier to diagnose if errors occur.

    Even if you used the built-in Plesk updater, try the yum (atomicrocketturtle.com) remember to show him kindness if it works....

    Question: before the Plesk install, did you install other package updates to the base FC2 install? it could be a matter of wrong package versions interfering with Plesk. Like just because PHP5 is out there, you can't use that version with Plesk yet.
     
  3. WebMonkey

    WebMonkey Guest

    0
     
    Ah, it is currently just the normal downloaded version of plesk with the demo (1 domain) license.

    Before the install I ran some update which updated the Fedora Core 2 components...this actually helped in installing. Do you think it could be causing issues then?

    I have run the yum updates...will keep you updated on this

    Many thanks, Paul
     
  4. WebMonkey

    WebMonkey Guest

    0
     
    I have just completed the yum update. It had a small problem at the end...it couldn't read packagemng, and it couldn't connect to mysql or something. I checked the status of mysql and it said mysql dead but sbusys locked. I restarted it and it is running fine now

    no change to the component info though

    thanks, paul
     
  5. WebMonkey

    WebMonkey Guest

    0
     
    I tried a fresh install (used the auto installer at first)....it came up with a similar problem..

    packagemng not found basically. Meant it couldn't complete the installation. Creating a completely blank file called packagemng meant it could complete the installation, but I have a feeling this is completely wrong and is probably why all of the components are grayed out.

    The installation doesn't appear to be creating the packagemng file, meaning it can't complete.

    What do I do?

    thanks, Paul
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Was it a fresh OS install as well?

    Are you using the following autoinstall file:

    psa_installer_v2.0.0_build72040920.10_os_FedoraCore_2_i686
     
  7. WebMonkey

    WebMonkey Guest

    0
     
    I think it's a fresh os install. I don't knoiw how to re-install fedora core 2...it was already on there when I started. Is there an automated installer for fedora core 2?

    yes, that was the file

    Thanks, Paul
     
  8. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The problem I have found with Plesk is that if you don't do what their instructions say, then you can run into problems.

    Since you don't know if it was a generic FC2 install, then it is possible that after the base FC2, there may have been many package updates to versions higher than compatible with Plesk 7.5.2, such as PHP5, etc.

    I've never done FC2, so I'm not sure what all is available for installing it. (sorry)

    Plesk normally likes having a minimal base OS install (no frills, just the basic services and packages). Then install Plesk, then (very carefully) update certain packages a little at a time and do testing!!!

    This is a more conservative way, but can save on lots of down time and frustration.

    Besides, everyone could do with a bit more patience these days... otherwise we'll end up with even more freeway drive-by shootings.... (as of today, L.A. is up to 8 freeway shootings in 2 months)
     
  9. WebMonkey

    WebMonkey Guest

    0
     
    Move to england, we don't get shootings. hehe

    right, ok. Do you know anywhere I could find out the easiest way to install fedora? Last I looked the CDs were about 600MB each, which is going to be alot to upload to the server as the server is remote to where I am

    thanks, Paul
     
  10. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Actually, my wife and I were thinking of that since we have grandkids there. But instead, they're coming over here!! (hooray)

    Depending on which part of GB, you still have a lot of clubbings, muggings, knifings, ASBO's, and physical violence from 'yobs' (i think that's the term). Midlands area...

    Did you buy this from a hosting company/data center?

    Ah, since it's remote, that would pose a problem, since to do a really 'fresh' install of the OS, you would have to wipe out what's there and really start 'fresh' ==wipe the drive.

    I gather this is not an 'in production' box, not actively hosting domains? If not, it may be better for you to take a trip to the box and really do it fresh.

    You may want to google for FC2 for sites, like www.fedoraforum.org
     
  11. WebMonkey

    WebMonkey Guest

    0
     
    Ah, it isn't so much it's noticable. I've never seen anything like it, only in the papers.

    Yeah, it's a dedicated server company. I do have access to it through a remote box, so installing wouldn't be a problem, it's just the issue of uploading. I could get it to boot from one cd if there was a way of letting it download everythign else itself

    How do you wipe a linux box and re set it up for fedora? I must confess I'm still learning about linux

    thanks,
     
  12. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Due to the amount of data, I don't think anyone would want to make the contents of the CD's available for download.

    I generally use fdisk or a partitioning utility to delete the partitions(s) and MBR.

    Then boot from the install CD (doesn't matter if it's RH9 or FC2), then the boot/installer would walk you through the rest.

    The other way would be for you to have a list of *all* packages & versions currently installed, then get with Plesk to see which ones would need to be downgraded or uninstalled before trying to do another fresh Plesk install.
     
  13. WebMonkey

    WebMonkey Guest

    0
     
    I think a fresh install would probably be the best way forward, then I know it's all on a level playing field and there aren't any randoms lying about the place

    Thanks for your help, if you get any sudden spouts of inspiration, the post will still be here. hehe. I definitely think you've earnt a 500g of cadburys finest....milk chocolate or fruit and nut? Co-op doesn't do anything else
     
  14. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Don't worry about it. Cadbury is good, but our See's Chocolate is the absolute best.

    Good luck to you.
     
  15. WebMonkey

    WebMonkey Guest

    0
     
    Didn't want to leave this thread without a conclusion (someone will write a book about it one day...you'll see!)

    Full reinstall of fedora core 2 (which I must say is the easiest thing in the world...don't even need to use a cd, can do it over the net) was fine and plesk successfully installed over the top.

    All is good!

    Until next problem...good night
     
  16. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I am glad that the fresh OS solved your problem.

    For other's reference, could you give a little detail as to how you installed FC2 over the net. That may save some other poor soul a lot of time and trouble...

    Thanks.
     
  17. WebMonkey

    WebMonkey Guest

    0
     
    Sure...

    INSTALLING FEDORA CORE 2 over the net

    First need to make it boot to the install program...so

    * mkdir /boot/f2install
    * wget -x -v -nd -P /boot/f2install -r -l 1 ftp://download.fedora.redhat.com/pub/fedora /linux/core/2/i386/os/isolinux/

    All the boot files are now there.

    Use:

    echo 'title Fedora 2 Install' >> /boot/grub/grub.conf

    echo 'root (hd0,0)' >> /boot/grub/grub.conf

    echo 'kernel /boot/f2install/vmlinuz ro root=LABEL=/' >> /boot/grub/grub.conf

    echo 'initrd /boot/f2install/initrd.img' >> /boot/grub/grub.conf

    root (hd0,0) - needs to be changed to match the other items in grub.conf
    I also found I needed to remove the /boot for the kernel and initrd as my /boot is a seperate partition

    Reboot the server and when it asks, select "Fedora 2 Install" from the menu. This will load and all you need to do is follow the on screen instructions which is very very easy.

    Select "FTP" when it asks for the type of installation. Use the following for FC2:

    download.fedora.redhat.com - as the host
    /pub/fedora/linux/core/2/i386/os/ - as the location. Presumably this could be changed to suit fedora core 1 or 3 if it was needed.

    Then you just need to sit back an wait while it downloads and installs the components that you specify through the GUI system.
    They have got that install absolutely dead right.

    All credit to JohnWhyles which is where I found this.

    Hope this helps anyone who was as stuck as I was!!
     
Loading...