• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

Issue Database Mangement problem

Dork

Regular Pleskian
Server operating system version
CentOS 7.9
Plesk version and microupdate number
18.0.60
The installed MariaDB is 5.5.68 and the upgrade tool ends with the following messages:

Removing previous mariadb-server provider ...
warning: /var/log/mariadb/mariadb.log saved as /var/log/mariadb/mariadb.log.rpmsave
Removing previous packages (mariadb-devel-5.5.68-1.el7.x86_64) ...
Upgrading packages (MariaDB-server MariaDB-client MariaDB-shared MariaDB-common MariaDB-devel) ...
Loaded plugins: fastestmirror
Determining fastest mirrors
* epel: fedora.tu-chemnitz.de
Resolving Dependencies
--> Running transaction check
---> Package MariaDB-client.x86_64 0:10.5.24-1.el7.centos will be obsoleting
---> Package MariaDB-common.x86_64 0:10.5.24-1.el7.centos will be installed
...--> Processing Dependency: mariadb(x86-64) = 1:5.5.68-1.el7 for package: 1:mariadb-bench-5.5.68-1.el7.x86_64
---> Package mariadb-libs.x86_64 1:5.5.68-1.el7 will be obsoleted
--> Running transaction check
---> Package boost-program-options.x86_64 0:1.53.0-28.el7 will be installed
---> Package mariadb.x86_64 1:5.5.68-1.el7 will be obsoleted
--> Processing Dependency: mariadb(x86-64) = 1:5.5.68-1.el7 for package: 1:mariadb-bench-5.5.68-1.el7.x86_64
---> Package socat.x86_64 0:1.7.3.2-2.el7 will be installed
--> Finished Dependency Resolution
Error: Package: 1:mariadb-bench-5.5.68-1.el7.x86_64 (@base)
Requires: mariadb(x86-64) = 1:5.5.68-1.el7
Removing: 1:mariadb-5.5.68-1.el7.x86_64 (@base)
mariadb(x86-64) = 1:5.5.68-1.el7
Obsoleted By: MariaDB-client-10.5.24-1.el7.centos.x86_64 (mariadb-main)
mariadb(x86-64) = 1:10.5.24-1.el7.centos
Available: MariaDB-client-10.4.31-1.el7.centos.x86_64 (mariadb)
mariadb(x86-64) = 1:10.4.31-1.el7.centos
... You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
plesk-mysql-server-18.0.2-2.centos.7+p18.0.44.0+t220518.2121.noarch has missing requires of mariadb-server >= ('0', '5.0.60', None)
 
Hi,

It seems that you have mixed repositories

You have a mix of 5.5 ( current ) and new ones 10.4 and 10.5

Remember than you first need upgrade mariadb 5.5 to 10.3 and then you can upgrade to 10.4 or newer

Please check plesk recomendations here: https://support.plesk.com/hc/en-us/...-5-to-5-6-5-7-or-MariaDB-5-5-to-10-x-on-Linux

When you say upgrade tool, you refer to new plesk tool to upgrade mariadb ?
No - I dont' have a mix but the tool seems to make a mix
Yes - it is the Database Management tool (as mentioned in the headline of the thread).
 
Back
Top