1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Debian and rblsmtpd

Discussion in 'Plesk for Linux - 8.x and Older' started by linsec, Sep 21, 2005.

  1. linsec

    linsec Guest

    0
     
    Hello,

    Im trying to get rblsmtpd to work using the standard psa provided package, however I dont believe it is working.

    After lots reading up on rblsmtp and how plesk uses it, I think my problem is related to the fact that debian still uses inetd instead of xinetd, and the plesk installer does not activate rblsmtpd in inetd.

    Here is my smtp line from inetd:

    smtp stream tcp nowait root /var/qmail/bin/tcp-env tcp-env /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true

    I cant see anywhere where it is running rblsmtpd. Anyone know the correct syntax in inetd when using rblsmtpd?

    This is probably a bug in the debian installer of plesk, im hoping i can just manually add the rblsmtpd command into the smtp line above.

    Any assistance will be appreciated.

    Cheers,

    Shane.
     
  2. Hal9000

    Hal9000 Guest

    0
     
    i can just confirm this problem.
    i have debian 3.1, installed a fresh copy of plesk 7.5.4 and do have this problem, there is no rblsmtpd in /etc/inetd.conf

    so i manually added rblsmtpd this way:

    smtp stream tcp nowait root /var/qmail/bin/tcp-env tcp-env -Rt0 /usr/sbin/rblsmtpd -r bl.spamcop.net -r relays.ordb.org /var/qmail/bin/relaylock /var/qmail/bin/greylist /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
     
  3. masterkain

    masterkain Guest

    0
     
    this will not work, smtp cannot accept new external connection after that change and spamassassin got errors such bad protocol: header error.
    any other ways to enable MAPS on debian?
    it is not a DNS problem.

    http://www.linuxsa.org.au/pipermail/linuxsa/2005-October/081194.html
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    There is this thread, see the posts from Shadowman and _Tek, he says he got it working by installing xinetd onto the debian server and then running rblsmtpd in xinetd.

    http://forum.plesk.com/showthread.php?postid=124153&highlight=debian+AND+smtp#post124151

    Post by Slydahunter on installing xinetd:
    http://forum.plesk.com/showthread.php?s=&postid=123941#post123941

    Note: I do not use Debian, all I am doing is posting links to additional information about your problem which I remembered seeing in previous posts. I hope this helps you find a solution.
     
  5. masterkain

    masterkain Guest

    0
     
    I've read almost everything about plesk 7.5 on these forum, I ended up installing greylisting. thanks.
     
Loading...