1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Dedicated Server - First Time

Discussion in 'Plesk for Linux - 8.x and Older' started by davidck, Nov 24, 2005.

  1. davidck

    davidck Guest

    0
     
    Hi,

    I just purchased a dedicated purchase and its setup under PLESK as control panel.

    here are few questions:

    1 - I have a domain name: citydesign.ca
    I want to make that point to the exclusive IP that my host has given me. How do I do that?
    Right now, what I did was to do the following:
    ns1.citydesign.ca 12.41.24.51
    ns2.citydesign.ca 12.41.24.51
    I pointed to the same IPs (I wonder if ns1.citydesign.ca works because I'm pointing to myself???)

    2 - When the nameserver changes are propagated, will something show up in PLESK or configured automatically? What step do I take??

    That's it for now, thanks.
     
  2. rvdmeer

    rvdmeer Guest

    0
     
    Sorry? could you explain one more time what you would like to do? its not clear to me what you exactly mean.
     
  3. ShadowMan@

    ShadowMan@ Guest

    0
     
    First, you need to login to your domain registrar account and change the primary/secondary nameservers to your IPs (I wasn't sure if that's what you did so I am just stating it in case).

    Then you need to login to Plesk and create the domain, setup physical hosting, make sure the domain's DNS records in Plesk are correct for what you need.

    Then after the registrar DNS changes are propagated to the top level gTLD nameservers, then DNS requests will be referred to your Plesk server to be processed.

    As of this moment, dnsstuff.com shows:
    So it looks like you may have done the registrar changes, but not setup the domain in Plesk. This would also cause dnsreport.com to show lame nameservers:
    After you setup the domain in Plesk, then you would need to upload your website file(s) to the domain's docroot, which is generally one of the following:

    /home/httpd/vhosts/citydesign.ca/httpdocs

    /var/www/vhosts/citydesign.ca/httpdocs

    This depends on your OS distro, and the directory would be created by Plesk when you setup the physical hosting in the control panel.

    And not to be rude, but you may also want to read the Plesk manuals to get some better idea of how things work. We here in the forums are usually glad to help, but cannot always be there at all moments...

    http://www.swsoft.com/en/products/plesk75reloaded/docs/
     
  4. davidck

    davidck Guest

    0
     
    Thanks for your response.

    I got the domain name to work.

    Since my server will also host other websites under my domain name, ex: ns1.citydesign.ca , ns2.citydesign.ca

    How do I make it so that another site , let's say: xxx.com uses the nameservers listed above?

    I've set up my DNS the same manner as:
    http://www.iblahblahblah.com/files/DNS-101Samples.txt

    The above tutorial ends with the SERVER DNS and PRIMARY WEBSITE DNS set up. My question is for the subsequent websites to set up under my newly created nameservers.

    Hope this is clear,
    Thanks
     
  5. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I had forgotten I had put that file there, I have since given that domain to my grandson LOL. I guess I'll have to check to see whatelse I forgot in that docroot....

    The tutorial (which I do need to update) ends with the Plesk Server's "DNS TEMPLATE" which is used as a base for all newly created domains. So if you wish for all other hosted domains to use your nameservers, modify the template to look like:
    Code:
    Server DNS Template sample:
    
    Host              Record type      Value	
    <domain>.         NS               ns1.citydesign.ca.	
    <domain>.         NS               ns2.citydesign.ca.	
    <domain>.         A                <ip>	
    webmail.<domain>. A                <ip>	
    mail.<domain>.    A                <ip>	
    ftp.<domain>.     CNAME            <domain>.	
    [url]www.[/url]<domain>.     CNAME            <domain>.	
    *.<domain>.       CNAME            <domain>.	
    <domain>.         MX     (10)      mail.<domain>.	
    <domain>.         TXT              "v=spf1 a mx ~all"
     
  6. davidck

    davidck Guest

    0
     
    Thanks for your tutorial , even if old, is extremely useful. Much better than the docs here...

    I'll make the changes you've posted.

    Also, another question, when I run dnsreport.com on citydesign.ca now, it has a few FAIL message. I'm concerned about some of them.

    :)
     
  7. ShadowMan@

    ShadowMan@ Guest

    0
     
    Code:
    FAIL	No NSs with CNAMEs	
    ERROR: ns1.citydesign.ca. has a CNAME entry (ns1.citydesign.ca.->citydesign.ca.); 
    it is not valid to have a CNAME entry and NS entries for ns1.citydesign.ca.. 
    See RFC1912 2.4 and RFC2181 10.3 for more information.
    
    ERROR: ns2.citydesign.ca. has a CNAME entry (ns2.citydesign.ca.->citydesign.ca.); 
    it is not valid to have a CNAME entry and NS entries for ns2.citydesign.ca.. 
    See RFC1912 2.4 and RFC2181 10.3 for more information.
    
    Note: This test checks with our local DNS server (since the NS record hostnames may not be
    handled by your DNS server), and therefore may be cached.
    This error is occurring due to your having a CNAME records for ns1/ns2.citydesign.ca

    Remove the unneeded CNAME records.
    Code:
    ERROR: The IP of one or more of your mail server(s) have no reverse DNS (PTR) entries
    Add a PTR record to your domain's DNS:
    ip.ad.dre.ss/24 PTR citydesign.ca

    Also make sure your Host/ISP has changed their rDNS (in.addr-arpa) zone to reflect your domain name.

    If we do a dnsstuff.com reverse DNS lookup on your domainname, it gives:
    Which leads me to believe that your (recent?) change of IP address has not propagated fully yet. I assume that 66.46.183.20 is your 'old' IP. You have submitted the nameserver IP changes to your domain registrar, right?

    Code:
    mail.citydesign.ca claims to be non-existent host inh0007.inovohost.com:
    220 inh0007.inovohost.com ESMTP 
    If you are on a VDS/Virtuozzo type server then I'm not sure you can do much about this. It's just a warning and currently should not prohibit proper operation of emails. If you are on your own dedicated server, then you could change the HOSTNAME of the server.
     
  8. davidck

    davidck Guest

    0
     
    No, 66.46.183.20 is indeed the correct one.
    http://www.citydesign.ca

    I erased the followng and still dnsreport.com is showing me error:
    *.citydesign.ca CNAME
    and
    verified that ptr for citydesign.ca does exist

    One part that I didn't get is to contact my HOST . What should I make them update?

    Thanks
    David
     
  9. ShadowMan@

    ShadowMan@ Guest

    0
     
    Ok, then I am confused. In your earlier post, you put 12.41.24.51, so I thought that was the current IP.

    If you actually removed the wildcard CNAME record, this is NOT what I said to do. You should only have removed the ns1.citydesign.ca and ns2.citydesign.ca CNAME records!

    Please post the current listing of your domain's DNS screen (just copy/paste the text) and put it in [ code ][ /code ] tags (without the spaces) in the reply screen here so it will be more readable.

    Also have you made sure your named/bind binary is running?

    ps -ax |grep named

    should show something like:

    4623 ? S 0:02 /usr/sbin/named -u named -c /etc/named.conf -u named -t /var/named/run-root

    which shows it is running in memory. Disregard the host/ISP statement for now, since it appears that the dns resolution is getting to your server.
     
  10. davidck

    davidck Guest

    0
     
    hi ShadowMan,

    I don't have the ns1/ns2 for CNAME that's why I deleted the * instead thinking that might have caused it. Here's my current DNS setup for CITYDESIGN.CA

    Code:
    citydesign.ca. NS ns1.citydesign.ca.  
    citydesign.ca. NS ns2.citydesign.ca.  
    citydesign.ca. A 66.46.183.20  
    mail.citydesign.ca. A 66.46.183.20  
    webmail.citydesign.ca. A 66.46.183.20  
    ftp.citydesign.ca. CNAME citydesign.ca.  
    [url]www.citydesign.ca.[/url] CNAME citydesign.ca.  
    citydesign.ca. MX (10) mail.citydesign.ca.  
    66.46.183.20 / 24 PTR citydesign.ca.  
    citydesign.ca. TXT "v=spf1 a mx ~all" 
    
    And this is for my SERVER one:
    Code:
    <domain>. NS ns1.citydesign.ca.  
    <domain>. NS ns2.citydesign.ca.  
    <domain>. A <ip>  
    <domain>. MX (10) mail.<domain>.  
    <domain>. TXT "v=spf1 a mx ~all"  
    ftp.<domain>. CNAME <domain>.  
    mail.<domain>. A <ip>  
    webmail.<domain>. A <ip>  
    [url]www.[/url]<domain>. CNAME <domain>. 
    

    Thanks, I've tried, by the way, setting 2 websites using the ns1.citydesign.ca and ns2.citydesign.ca with the following URLs:
    http://www.millionsties.com
    http://www.sugoidesign.com

    They showed up in DNSREPORT.COM but maybe the changes are not propagated to Canada yet.
     
  11. ShadowMan@

    ShadowMan@ Guest

    0
     
    Yes, it may be a propagation issue. I am seeing that your ns2 resolves to the IP, but the ns1 does not.
    You may want to login to your domain registrar and re-submit the ns1 nameserver and IP just to be sure it went through ok. I have seen on rare occasions where something went wrong and had to re-submit the info to the registrar.

    I would go ahead and add the following to the domain's DNS:

    ns1.citydesign.ca. A 66.46.183.20
    ns2.citydesign.ca. A 66.46.183.20


    Only to your main hosting domain's DNS, not the template.
    Then add the following to both the domain DNS and the template:
    *.citydesign.ca. CNAME citydesign.ca.
     
  12. davidck

    davidck Guest

    0
     
    Code:
     IP Address Subnet Mask Interface Clients Hosting  
      66.46.183.20 255.255.248.0 eth0 1 1  
      192.168.111.2 255.255.255.0 eth0 1 1  
      192.168.111.88 255.255.255.0 eth0 1 1 
    
    For the 2 websites I'm trying to create, do they need to be in the same subnet mask as the main IP 66.46.183.20 ??

    Also, the ips 192.168 are internal ips, would that be a problem?

    This is what I have right now for one of the new domain:
    Code:
    millionsties.com. NS ns1.citydesign.ca.  
    millionsties.com. NS ns2.citydesign.ca.  
    mail.millionsties.com. A 192.168.111.88  
    millionsties.com. A 192.168.111.88  
    webmail.millionsties.com. A 192.168.111.88  
    ftp.millionsties.com. CNAME millionsties.com.  
    [url]www.millionsties.com.[/url] CNAME millionsties.com.  
    *.millionsties.com. CNAME citydesign.ca.  
    millionsties.com. MX (10) mail.millionsties.com.  
    millionsties.com. TXT "v=spf1 a mx ~all" 
    
     
  13. ShadowMan@

    ShadowMan@ Guest

    0
     
    You do know that 192.168.x.x is non-routable on the internet, you would not want to assign 'private' IPs to hosted domains.

    Yes, the domain is showing up in the dnsstuff.com lookup, but if you notice, it is reporting the A record as the 192.168.xx.yy address, which nobody will be able to browse to since it is a non-routable IP.
     
  14. davidck

    davidck Guest

    0
     
    Everything works good now, thanks alot ShadowMan.
     
Loading...