1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

DESPERATE FTP - Client cannot log in. - Home Directory Inccessable

Discussion in 'Plesk for Windows - 8.x and Older' started by marcwolf, Aug 9, 2004.

  1. marcwolf

    marcwolf Guest

    0
     
    I have a brand new install of Plesk 7 on an Windows 2003 Server. I have set up all of the users and domains correctly. Thats all works.

    However when any of my clients try to connect using FTP the system logs them in and then come up with a

    PHP:
    530 User acme cannot log inhome directory inaccessible.
    This is holding up several of our most important clients from moving onto this server.

    This is my first time using Plesk and I hope that my issues are not a prelude to continuing problems.

    Many Thanks

    Dave
     
  2. siren@

    siren@ Guest

    0
     
    Go into "Computer Management" from the Administration on the start menu. Go to users, find the user. Open it up and verify the settings. Use another user listed that does work as a template to verify by just editing the appropriate spots.

    Then find the domain.com folder under where you installed the domain data to. Verfiy the user has permissions properly for this folder.
     
  3. marcwolf

    marcwolf Guest

    0
     
    There are NO users that can FTP into the system.

    Many thanks for replying.. (Online now)
     
  4. siren@

    siren@ Guest

    0
     
    Check your permissions on there home directories. Make sure they have list permissions at least.

    Verify in the computer management under the users properties that there home directory is mapped properly to the domain folder.
     
  5. marcwolf

    marcwolf Guest

    0
     
    Have Done.. It is mapped.

    I'm on AIM as 'Anubis Syst'

    Care to chat - be faster that way..

    Many Thanls

    Dave
     
  6. siren@

    siren@ Guest

    0
     
    Not much for IM at the moment.

    Other than those two and verifying that FTP Server is running I would have to look and we are at a point with as much going on as we do that I can't do that free anymore.

    Maybe somebody else would have some more ideas.

    You can email me though
    "larry'at'ddihosting.net"
     
  7. anajera

    anajera Guest

    0
     
    Problems Using FTP as well

    I also get that user cant login, home directory inacessible and Ive tried everything listed here as well as well as searching microsofts site, if it was something with IIS.

    Im running Plesk 7.0 on a windows 2000 machine with all of the updated service packs.

    -dre
     
  8. marcwolf

    marcwolf Guest

    0
     
    I got an answer from the Plesk people on this

    Check your Machine Name

    If it is greater than 15 Characters then FTP will no work.

    I've changed this on mine and it is working now

    Just passing on what the developers emailed me. They managed to fix it very quickly.

    Take Care

    Dave
     
  9. anajera

    anajera Guest

    0
     
    Thanks for your response, My computer name is only 11 characters though.. but Maybe Ill rename it just to see.

    Over 15 characters though that is weird.
     
  10. SupermanInNY

    SupermanInNY Guest

    0
     
    I had this issue. .but resolved it fairly simple:

    Chances are you have your users use the WRONG IP.

    If your primary IP is xxx.yyy.xxx.111
    and you set your users to be on a shared IP say xxx.yyy.xxx.112, but you tell them to use the xxx.yyy.xxx.111 then you will get this error.

    Make sure they use the IP address you assigned them in the setup,.. otherwise they will be routed to a different directory where they correctly do not have permissions.

    Hope that helps.

    -Alon.
     
  11. anajera

    anajera Guest

    0
     
    nope they are using exclusive Ips, so they are not sharing IPs.. Ive checked the permissions to the folder they are trying to FTP to and they have permissions to it. Im not sure what else to do, I may just reinstall it...
     
  12. MattR@

    MattR@ Guest

    0
     
    Under 6.5 we've had this issue when trying to FTP to a host name verus the IP, I'm not sure why however they would get the "Host Directory Unavailable" error if FTPing to ftp.domainname.com however they would not if FTPing to the ip that this resolves to, making sure DNS had propegated, etc. We never found an explanation but we did see this happening here, possibly something to verify before re-installing.
     
  13. Maxx

    Maxx Guest

    0
     
    I had this problem last night. I ended up just with this solution...



    Browser solution is

    ftp://yourdomain.com

    browser login box pops up they put in login and pword and there they are.


    in WinFTP its just domainname.com and user name and log in set up in config at opening.

    I was trying at one point mydomain.com/newaccountuser/ and that was not working. I just told it to hit the domain only and it worked. All ips set to exclusive. In Area where you have Anon FTP was also not allowed and I kept it that way.


    Maxx
     
  14. shwonder

    shwonder Guest

    0
     
    Sometimes it happens when computer name length is more than 15 symbols.
    Right click on MyComputer -> Properties -> Computer name -> Change, change text in edit box 'Computer name'.
    It's length should not be more than 15 symbols.

    Best regards.
     
  15. owebtech

    owebtech Guest

    0
     
    So I found a solution to this problem. I had 7.5 installed and installed Active Directory on top of it, screwing up the Plesk permissions, leading to this error.

    I then upgraded to 7.6 but had the same problem. However, I noticed that any new account I made had access to the ftp. Here is the solution I found:

    1. Login in to plesk
    2. Click Domains on the left
    3. Select the/any domain that is having the problem
    4. Click Setup under Hosting
    5. Add a "1" after the ftp login, so if it was "loginname", change it to "loginname1".
    6. Enter a password (can be the same as old one). This is a MUST! You will get an error if you leave the password field blank.
    7. Click Ok.
    8. Test the FTP with the new login name. It should work.
    9. Click Setup again.
    10. Remove the "1". You do not need the password this time.
    11. Done!
      [/list=1]
      I dont think the 15 character name is a problem b/c mine is 24 chars long (its on a domain so its name.srv.domain.com).

      Hope this helps!
     
  16. ThuNguyen

    ThuNguyen Guest

    0
     
    Thx,

    Changing the username fixed the issue.
     
Loading...