1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Difference between domains when php in CGI

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by IvoB, Nov 25, 2010.

  1. IvoB

    IvoB Guest

    0
     
    I have a strange difference between several domains on my server. I have PLESK 9.5.2 with php 5.1

    For a Magento webshop i needed php 5.2. So for one domain I run php 5.2 in the cgi-bin, set the right permissions and added a htaccess. Works like a charme.

    Now i wanted to do the same thing for another domain. But is does not work anymore.
    I have exactly the same setting for the domain setup and exactly the same permissions set for all files and directories.

    When i try to reach a file on the domain I get: 500 Internal Server Error
    In the log file it says: Premature end of script headers: php5-cgi

    Both domains were allready setup some time ago on a different server. The whole PLESK was migrated to a new machine. The domain with the working webshop still worked after the migration.
    The domain that does not work was already on the server, but setup with php 5.2 after the migrition.

    I also tried to setup the same thing on a subdomain of the working domain. But also no luck and the same error.

    Anybody a solution ? Tnx.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,547
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
  3. IvoB

    IvoB Guest

    0
     
    Yes i read that thread.
    I tried the permissions and that did not work. The permissions (for the files and directories) are all exactly the same a the domain that does work.

    The thing about the suexec is a step to far for me at the moment.
    Does this file tell something about the complete server or does it describe something for each domain ? (because i have a working domain)
    Is it likely that the problem could be with the suexec?

    Tnx!
     
  4. IvoB

    IvoB Guest

    0
     
    Still no success

    Anybody any idea about this case ? Please
    I still can not make it work.
     
  5. IvoB

    IvoB Guest

    0
     
    Zend Optimizer?

    Someone gave a tip that it could have something to do with the Send Optimizer. I would have to update it.
    Could this be a solution ?
     
Loading...