• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

Disabling TLS for qmail-send

J

jhghjgh hjghgkh

Guest
My server is unable to send mail to a particular remote SMTP server - mail bounces back with 'TLS connection failed' ("(error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol)"). I suspect the remote server is advertising that it supports SSL when in fact it doesn't (my server can use SSL when communicating with other SMTP servers fine).

Is there a way to stop qmail-send from attempting to use TLS when talking to this host? I may even have to go down the route of disabling TLS completely, but can't find a way to do that.

Any thoughts please?
 
I really need to do this as well with an 8.6 system. I have looked all over for information on how to do this. If anyone can help or point me in the right direction it would be appreciated.
 
I'm half way to finding a solution - I should have been reading up on qmail-remote, not qmail-send ...

http://inoa.net/qmail-tls/qmail-remote.txt

notlshosts/<FQDN>
qmail-remote will not try TLS on servers for which
this file exists (<FQDN> is the fully-qualified
domain name of the server). (tlshosts/<FQDN>.pem
takes precedence over this file however).

Going to try that shortly...
 
I'm guessing this didn't end up working? I can't find any reference to notlshosts in the qmail-remote binary that Plesk bundles so I'm thinking they're not using that specific TLS patch.
 
Same problem here.. Has anyone solved this one yet?

qmail: 1436649830.795551 delivery 3: deferral: TLS_connect_failed:_error:14082174:SSL_routines:SSL3_CHECK_CERT_AND_ALGORITHM:dh_key_too_small;_connected_to_69.94.125.39./
 
You need to switch to postfix; the qmail-send included with Plesk has numerous issues on today's internet; sslv3, dh keys <1024, all email goes out the first ip, etc.
 
Back
Top