1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

dns bind faild"managed-keys-zone ./IN: loading from master file managed-keys.bind fai

Discussion in 'Plesk 9.x for Windows Suggestions and Feedback' started by majid alavizadeh, Feb 11, 2011.

  1. majid alavizadeh

    majid alavizadeh Guest

    0
     
    Hi

    I use plesk 9.5.3 and dns fail every few minutes:

    managed-keys-zone ./IN: loading from master file managed-keys.bind failed: file not found


    Please help me its urgent for me
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Just create empty this file. The file "managed-keys.bind" is used for managing keys in DNSSEC. By default, BIND is looking for it. Even though you might not be using this feature, creating the file in empty will make the error message go away.
     
  3. MzaNike

    MzaNike Basic Pleskian

    24
    23%
    Joined:
    May 11, 2005
    Messages:
    63
    Likes Received:
    0
    The same

    where do I create it?
    Does it goes together with:
    "zone 0.0.127.in-addr.arpa/IN: not loaded due to errors." and
    "zone 0.0.127.in-addr.arpa/IN: NS 'myserver.de.0.0.127.in-addr.arpa' has no address records (A or AAAA)"?
     
  4. christiant123

    christiant123 Guest

    0
     
    This tip ist very fat ****!

    The missing file exists in /etc/bind/ and is named bind.keys

    In standard- /etc/bind/named.conf ist a config-error .

    Originally it looks
    there fails an entry

    Edit /etc/bind/named.conf to

    save the file and restart bind.

    Thats all!

    Not using this feature is a security risk, workers of Parallels should know and give better infos!
     
    Last edited by a moderator: Aug 9, 2011
  5. AgamemnonS

    AgamemnonS Guest

    0
     
    'christiant123' your tip is a BULL **** ... RTFM ... before post.

    This is a part of comments found in the "bind.keys" file.

    This is not a problem if you are not using DNSSEC 'majid alavizadeh' and your BIND9 is working properly.
    BUT if you don't want to see this error in your logs again then here is the solution.

    Look in "named.conf.options" and check the option "directory" (default is "/var/cache/bind") which is the path of the working directory, go there and create an empty file "managed-keys.bind" with write and read permissions on the BIND9's user (default is "bind").

    OR

    Add this in the "named.conf.options" file:

    and create an empty file "managed-keys.bind" in the "/etc/bind" folder.

    That's all folks!!! Cheers!!!
     
    Last edited by a moderator: Aug 20, 2011
  6. quenenniq

    quenenniq Guest

    0
     
    well, I tried both solutions (christiant123 & AgamemnonS)


    from AgamemnonS:

    the file '/var/cache/bind/managed-keys.bind' already existed there, with the right ownership

    I then tried your second solution, with the option managed-keys-directory "/etc/bind"; in named.conf.options and by creating an empty "managed-keys.bind" file in /etc/bind with bind as owner of the file, but after that, I couldn't start my bind server anymore.

    ==> ../bind/bind.log <==
    01-Dec-2011 20:35:12.294 general: error: journal.c:171: unexpected error:
    01-Dec-2011 20:35:12.294 general: error: missing SOA


    from christiant123

    I then tried that solution and added include "/etc/bind/bind.keys"; in named.conf.
    Same error on restart.

    I then changed the ownership of the 'bind.keys' file, who had root ownership, to bind and it worked.


    I'm no expert with bind, as I only use it to play on my small home lan network, so I can't say why it wasn't working with the first solution, but anyway, thanks for giving me a solution to this problem.

    I'll RTFM for sure one day :p
     
  7. MemoonaM

    MemoonaM Guest

    0
     
    Thanks for the discussion and for your kind reply.
     
  8. FatanehE

    FatanehE Basic Pleskian

    20
    90%
    Joined:
    Sep 2, 2009
    Messages:
    41
    Likes Received:
    0
    Finally which solution is correct?
    I have same problem with my plesk 9.5.4 version.
    but I don't have "/etc/bind" path in my server. I see "dns/etc/named.conf" !!!

    Thanks,
     
Loading...