1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

DNS & FTP Problems

Discussion in 'Plesk for Linux - 8.x and Older' started by Jorijn, Jan 18, 2006.

  1. Jorijn

    Jorijn Guest

    0
     
    Ok, here's my situation:

    I got a bunch of ip's,
    FTP isnt running,
    and Nameserver-less

    Question 1, How do i set up the first nameservers? I have enough ip's

    Question 2, FTP isnt running, how do i start it?

    Question 3. in the services menu, it says BIND isnt running, when i press start, i get this:

    ERROR
    Up LevelUp Level
    Unable to make action: Unable to manage service by dnsmng: dnsmng: Service named failed to start
    0: /usr/local/psa/admin/htdocs/server/restart_services.php:28 psaerror(string "Unable to make action: Unable to manage service by dnsmng: dnsmng: Service named failed to start")

    anyone know how to get this machine up and running witouth problems?
     
  2. poke

    poke Guest

    0
     
    http://faq.sw-soft.com/article_16_1025_en.html
    Please check what superserver is used in the system. If you run xinetd you should create configuration file for FTP service because by
    default Plesk deb package configures proftpd with inetd.

    --------- IMPORTANT INFORMATION FOR XINETD USERS ----------
    The following line will be added to your /etc/inetd.conf file:

    ftp stream tcp nowait root /usr/sbin/tcpd in.proftpd

    If you are indeed using xinetd, you will have to convert the above into
    /etc/xinetd.conf format, and add it manually. See
    /usr/share/doc/xinetd/README.Debian for more information.
    ----------------------------------------------------------

    So you should create /etc/xinetd.d/ftp_psa like:

    service ftp
    {
    disable = no
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    instances = UNLIMITED
    server = /usr/sbin/in.proftpd
    server_args = -c /etc/proftpd.conf
    }

    And restarted xinetd with "/etc/init.d/xinetd restart". After that ftp should work.
     
  3. Jorijn

    Jorijn Guest

    0
     
    The server is running Red Hat.. no debian :x
     
  4. Jorijn

    Jorijn Guest

    0
     
    Wow.. you're being very helpfull .. :rolleyes:
     
Loading...