1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

domain.com:8443 gives redirects to "localhost.localdomain"

Discussion in 'Plesk for Linux - 8.x and Older' started by Dragons Master, Aug 20, 2005.

  1. Dragons Master

    Dragons Master Guest

    0
     
    Heya Folks,

    Whenever I hit www.domain.com:8443 the browser tries to ge to "localhost.localdomain" - now I assume it's some configuaration file not set properly but when I search for file containing "localhost.localdomain" I get quite a big list - I suppose some of them should actually have that in them because except for the 8443 port going mad everything works perfect.

    Anyone has an idea how to change it to the real localhost and localdomain needed?

    Thanks,
    - Ben
     
  2. BillyParadise

    BillyParadise Guest

    0
     
    Your /etc/hosts file is messed up.

    1.2.3.4 www.example.com www
    1.2.3.4 www.example.com.

    (assuming you want to call the box www.example.com)

    also check out /etc/rc.conf if you are on FreeBSD, or something like /etc/HOSTNAME is you are on linux.

    Best of luck.
    BP
     
  3. mian

    mian Guest

    0
     
    set your hostname to the proper one in settings
     
  4. Dragons Master

    Dragons Master Guest

    0
     
    mian, the "full hostname" was already set.

    BillyParadise, thank you so much it appears like that is what solved that - though when I gave it a second look it appears like just using https made it work too - but for the sake of lazyness i applied your fix and it worked - I can now go to http://www.domain.com:8443 and it brings up plesk :) thank you!
     
  5. damogill

    damogill Guest

    0
     
    I had this after upgrading to 10.2 and have edited the host file but it still redirects to

    https://localhost.localdomain:8443/relay

    I have left these two lines in

    I have added a 3rd line with my internet IP and internet hostname

    :( Any idea what else it could be?
     
  6. damogill

    damogill Guest

    0
     
    Changed the loopback line to use the external FQDN and the hostname as well but still no luck :(

    Anyone have any idea what I can do? It seems to redirect to https://localhost.localdomain:8443/relay

    Not sure what this relay bit is. if I hit esc on my browser as it redirects the bit before that is

    https://x.x.x.x:8443/login_up.php3?window_id=&requested_url=https://x.x.x.x:8443/

    My /etc/hosts is as follows.

    Have changed my Ip to something random, this isnt the actual IP of course :)
     
  7. BenoitP

    BenoitP Guest

    0
     
    Hi,

    I have the same problem, when i try to connect on this adress "https://my-domain:8443/", I'm redirect to "https://127.0.0.1:8443/relay"

    Any Idea ?

    Thx
     
  8. BenoitP

    BenoitP Guest

    0
     
Loading...