1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

domain.com/plesk-stat broken

Discussion in 'Plesk for Linux - 8.x and Older' started by webjfg, Apr 1, 2006.

  1. webjfg

    webjfg Basic Pleskian

    24
    40%
    Joined:
    Jun 8, 2005
    Messages:
    39
    Likes Received:
    0
    HI
    after upgrading from 7.5.4 to 8.0.0 (fc2) user can't acces domaine.com/plesk-stat

    it ask dor the username / password but i receive error 403 You don't have permission to access /plesk-stat/ on this server.

    thanks

    JF
     
  2. MikePaul99

    MikePaul99 Guest

    0
     
    I've noticed this as well with a couple of domains, works on some but not on others. Happened before the upgrade so it's not 8.0.0 specific.
     
  3. !Blob!

    !Blob! Guest

    0
     
    I've a big problem with /plesk-stat/ directory. I've googled, browsed this forum (and some others) - nothing.

    The question is: what is the username and password to that directory? I've couple domains configured and running smooth. With every single one I've tried the following:
    - plesk login, plesk password, FTP login, FTP password (and varieties)
    - accessing it by domain.com/plesk-stat/ domain.com/webstat/ domain.com/plesk-stat/webstat/ etc.
    ...and nothing. I can't log in.

    Debian is the OS with two weeks old Plesk 8 on board. I expected some problems but this one I can't solve by myself...

    Anyone help?
     
  4. MikePaul99

    MikePaul99 Guest

    0
     
  5. !Blob!

    !Blob! Guest

    0
     
    The owner:group of all /statistics/ IS root:psaserv. Just none of login/password combination is really working. I have no clue what's wrong.

    Ps. root:psacln is not working either...
     
  6. MikePaul99

    MikePaul99 Guest

    0
     
    That's what I thought too, then I ran the command specified above and I was then able to access the stats.
     
  7. !Blob!

    !Blob! Guest

    0
     
    Ok, run this command (poiting to correct directory), and.. nothing changed. Any other ideas?
     
  8. troymc

    troymc Guest

    0
     
    I have this same problem. I also have this problem on my test box which is a fresh install of Plesk 8.0 on fc2.
     
  9. MikePaul99

    MikePaul99 Guest

    0
     
    All I can tell you is that I ran the command above, unmodified, and it worked.

    Is your webspace outside of the /home directory?
     
  10. wizbones

    wizbones Guest

    0
     
    Finally it works - cool beans - not sure why it isn't working for you !Blob!

    If you turn off the password protection can you at least display the stats at all? http://domain.com/plesk-stat/webstat ?

    Before applying the fix above, I could display the stats if it was unprotected but couldn't if it was.

    If you cannot display with protection off then you have a deeper issue.
     
  11. !Blob!

    !Blob! Guest

    0
     
    Turned off password protection - working. Turned on - not working.

    Applied root:psaserv to whole statistics/ and below. Nothing changed.

    But thank you for the hint.

    The problem was ownership of password files located in pd/. My server had confixxx before, but I thought that it was wiped out completly, but no: pd/* was www-data:www-data which is not currently used in my configuration.

    The solution:
    Code:
    chown psaadm:psaserv /var/www/vhosts/*/pd/*
    (instead of :psaserv it could be anything since files are 0400)
     
Loading...