1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

domain ip change

Discussion in 'Plesk for Linux - 8.x and Older' started by Ronaldve, Jan 11, 2005.

  1. Ronaldve

    Ronaldve Guest

    0
     
    I've moved a domain from one ip-address to another ip-address on the same machine.
    DNS settings changed automaticly, but when i'm going to that domain i'm getting the plesk default page and not the website.
    I've got no idea why this is. Does someone knows how to fix this?

    I dont think this has to do with the dns propagation, because the dns servers didn't change.
     
  2. akucharski

    akucharski Guest

    0
     
    same problem

    how did you resolve this?...
     
  3. thedust2010

    thedust2010 Guest

    0
     
    I have had the same problem... tried installing an SSL and moving the domain over to a new IP and ever since then no matter what IP I assign the website, I am seeing the default Plesk page. No good. Any advice???
     
  4. akucharski

    akucharski Guest

    0
     
    Well, so far what I have is this:

    domain on new exclusive ip: default plesk page

    domain on shared ip: OK

    domain back on exclusive ip: default plesk page

    I wonder if there is something wrong with this IP, so I am getting some new ones installed and will test with that. The annoying thing about it is that the ip takes a while to change sometimes, cant figure this out either.
     
  5. thedust2010

    thedust2010 Guest

    0
     
    Yes, after a while the website displayed properly. I have no idea why it took some time to change over.

    My network administrator gave me this information:

    All DNS records have a TTL (Time To Live) setting. When a computer does a look up on that record it will keep it cached for however long the TTL is set for before going out and looking for it again. The normal setting for this is 1 hour.

    Usually when we do DNS updates we inform the customer there is a 1 hour window for the changes to propgate through but they will most likely see the changes much sooner than that.
     
  6. akucharski

    akucharski Guest

    0
     
    By the way, this also happaned with my other exlusive ip sites but a httpd restart did the job (service httpd restart).
     
  7. whoisjb

    whoisjb Guest

    0
     
    This happens to me every time I update a domain to either a static IP address or a shared IP, doesn't matter. But, for some reason Plesk doesn't seem to know that the change was made.

    I've tried running this command:
    /usr/local/psa/admin/sbin/websrvmng --reconfigure-all

    I've also restarted httpd and my dns and it still shows the Plesk default page. WTF?

    I checked the httpd.include files and it's correctly showing the IP change so why does the Plesk server refuse to recognize these updates?

    I really don't think this has anything to do with TTL with DNS. I wish someone from Plesk would jump in and give us a definitive answer!
     
  8. tmonsen

    tmonsen Guest

    0
     
    Ronaldve,

    The problem isn't that plesk, or your dns servers hasn't update the change. The problem is with your local network/ISP. One of the nodes on your network, is caching the old IP information. This can be anything from your computer, a mini-router, to an ISP's server or routing equipment. Once the cache on the offending equipment is cleared the, equipment will do a new lookup from your dns servers, and then report the correct IP. On my own network, powering cycling my mini-router will often fix the issue.

    If you want to verify the name servers are returning the correct information, do the following from a shell:

    dig @ns.dnsserver.tld domain.tld

    One way to verify if your computer is trying to access the new IP or the old IP is to ping the domain from a command prompt:

    for those who need instructions for this:

    start -> run -> command -> click ok, in the window that opens, type ping domain.tld -> hit enter.

    You will either receive the new IP, in which case you should also see the website properly. If you see the old IP, you'll need to wait for the cache on your network to clear.

    Hope this helps clear up the problem.
     
  9. phingers

    phingers Guest

    0
     
    same problem any ideas?

    I have the same problem. Have domain1.com on the shared IP, Got the SSL installed, and a new IP assigned, switched the domain over to the exclusive IP address.

    Restarted the webserver, and I get the default domain.

    I've checked DIG and my local computer, all are reporting the NEW IP that is assigned.

    The httpd.include file for the domain1.com account shows the new IP address in there.

    Still the default plesk domain page is coming up.

    I've tried the

    /usr/local/psa/admin/bin/websrvmng -u --vhost-name=domain1.com

    And then restarted the web server again, still the same problem?

    How do I fix this? Any ideas are appreciated.

    Thanks!

    -Bryan
     
Loading...