1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Email hosted elsewhere

Discussion in 'Plesk for Linux - 8.x and Older' started by jbouvier, Dec 15, 2005.

  1. jbouvier

    jbouvier Guest


    I have a domain that is hosted on another server from my Plesk machine. What needs to be done to configure the system to deliver messages sent from other domains on this server.


    foo.com is hosted on server a and has email on server b
    bar.com is hosted on server a and has email on server a

    Messages from bar.com to foo.com are not being routed to server b, but need to be.

    The MX records are setup correctly.
  2. Who-m3

    Who-m3 Guest

    Verify that the MX records are properly set to take foo.com e-mail to the b server. You can do this by utilizing www.dnsreports.com (very useful, ignore the warning regarding dns serials, it's a plesk thing, not everyone likes it, it's not an option (yet)).

    It should indicate that the priority for your MX says that e-mail for foo.com sends to b server. If that is correct, a test e-mail should be sent to verify that it is working properly from an external source (hotmail, etc).

    Next, you'll want to make SURE to disable the e-mail functions for the foo.com domain on server a. Login to the Plesk Admin Panel, go to the Client that the domain is in, then to the Domain, then click on Mail. You'll see in the far left corner of the page, "Disable". Click on it.

    Now you want to test an e-mail to foo.com from server a. Login to another account (perhaps that of bar.com) to send an e-mail to foo.com. This should send to the external source, allowing the email to properly route.

    Now, since you've verified that, check both domains with www.dnsreports.com to verify that all your settings are properly configured. Make sure to have SPF records, as a lot of companies these days will give you issues if you don't.

    Any more assistance I'd be happy to provide, just drop me a note through the site, or reply to this post. -John
  3. ShadowMan@

    ShadowMan@ Guest

    On the Plesk server, you also need to make a couple of minor changes to the /var/qmail/control files:

    morercpthosts: add the domain to this file (does not exist by default, create a new file)
    rcpthosts: make sure the domain is NOT in this file which gets overwritten by Plesk
    smtproutes: create this file and put a line specifying the domain.com:ip.add.re.ss:port
    (if port is the standard 25, then it can be omitted, I usually put it in anyways)

    Restart services.
  4. m1bxd

    m1bxd Guest

    Return-Path: <anonymous@p15145013.pureserver.info>
    Delivery-Date: Thu, 22 Dec 2005 22:49:31 +0100
    Received: from [] (helo=p15145013.pureserver.info)
    by mx.kundenserver.de (node=mxeu2) with ESMTP (Nemesis),
    id 0MKpdM-1EpYJX2HQC-0000rx for mark@mydomain.co.uk; Thu, 22 Dec 2005 22:49:31 +0100
    Received: (qmail 22188 invoked by uid 48); 22 Dec 2005 22:02:27 -0000
    Date: 22 Dec 2005 22:02:27 -0000
    Message-ID: <20051222220227.22187.qmail@p15145013.pureserver.info>
    To: mark@mydomain.co.uk
    Subject: Lisa - what about tonight
    From: anonymous@p15145013.pureserver.info
    Reply-To: anonymous@p15145013.pureserver.info
    X-Mailer: PHP/4.3.10
    Envelope-To: mark@mydomain.co.uk
    X-SpamScore: 0.339
    tests= NO_REAL_NAME

    morercpthosts: [ADDED]
    rcpthosts: [Yup it's clear]



    If this the right entry? Where that machine is the MX record for the domain in question and that's it's IP?

    Return-Path: <anonymous@p15145013.pureserver.info>

    Hotmail thinks that email from the server is spam!

    ahh! - can this be cured?

    Cheers Mark