1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Error 997: Plesk Management Service

Discussion in 'Plesk for Windows - 8.x and Older' started by mitchkill, Oct 31, 2005.

  1. mitchkill

    mitchkill Guest

    0
     
    Yesterday my Plesk Management Service began to fail. Whenever I try to start the service it gives "Error 997 at Start service plesksrv: Overlapped I/O is in process" I have tried to go to the PleskDir\admin\bin and run "plesksrv -uninstall" and "plesksrv -reinstall" but to no affect. I have seen forum entries for Error 997 on the Plesk Control Panel service but not for the Plesk Management Service. Anybody have any ideas? I am running Plesk 7.5/Windows 2003. Thanks.
     
  2. mitchkill

    mitchkill Guest

    0
     
    A little more information I have dug up...
    In the event log after a few minutes, an application entry is generated for RunTask.exe. The message is as follows:
    So it seems that the problem is with something that is being passed to runtask. Apparently it is trying to run two processes at once or something. Is there anyway that I can figure out what is being sent to RunTask? Thanks!
     
  3. JAFO@

    JAFO@ Guest

    0
     
    Hi!
    There is 'repair permissions on root folders' in reconfigurator of Plesk 7.5.4 Try setting them up.
    bye!
     
  4. mitchkill

    mitchkill Guest

    0
     
    Thanks for the reply. I ran the Reconfigurator option to Repair Plesk Installation->Plesk File Security settings and to repair the Services, it came up with three warnings and an error message.

    1) Error cannot start PleskControlPanel:System error is 'Cannot start service
    PleskControlService on computer.'
    2) Error cannot start PleskControlPanel:System error is 'Cannot start service PleskControlService on computer.'
    3) Cannot start service plesksrv System error is: Time out has expired and operation has not been completed

    And the error:
    1) Error 2 at connect to pipe: The system cannot find the file specified.

    I will add that the service PleskControlPanel has not been starting either. The error that is returned is "The operation has timed out" I assumed that this was caused because of the error with Plesk Management, but I may be incorrect. Anyone have any more ideas?
     
  5. mitchkill

    mitchkill Guest

    0
     
    After some more scratching around, I think that the problem is that Plesk cannot connect to the database. Somehow or another there is a password discrepancy. So I run the plesksrvclient.exe file and it says that it cannot connect to the MySQL db. I put in my MySQL password and it gives the "Error 2 at connect to pipe: The system cannot find the file specified" error. So apparently whatever file that it writes the password too has disappeared or is not accessible because of permissions. If I could find which file PleskSrvClient is referring to, I might be able to fix it. Anyone have any ideas?
     
  6. jbuts

    jbuts Guest

    0
     
    Maybe the "http://kb.swsoft.com/article_150_922_en.html" will help you.
     
  7. mitchkill

    mitchkill Guest

    0
     
    As I said in the previous post, the plesksrvclient.exe program throws an error. When I run plesksrvclient.exe -get I get a runtime error. I wish there were a little more technical info about this plesksrvclient utility, e.g. which files it is attempting to write to.
     
  8. vekna

    vekna Guest

    0
     
    Hmmm - it is a seriouse problem.

    You can try to recompile Plesk - Use:
    defpackagemng --fix (it is very dangerous command!!!)

    or you can try reinstall basic Plesk components
    Go Add\remove programs - Plesk - Repair.
     
  9. susheel

    susheel Guest

    0
     
    hi,
    Did you guys manage to find a resolution? I am also stuck up with the same problem badly!
    Awaiting,

    Susheel
     
  10. alper

    alper New Pleskian

    22
     
    Joined:
    Apr 23, 2006
    Messages:
    3
    Likes Received:
    0
    me tooo
     
  11. Gris@

    Gris@ Guest

    0
     
    Overlapped I/O is in process
    error means that this service is in stopping state.
    check system services.
    It seems that Plesk Controll panel is in stopping state. You will not be able just stop or start it in this state. You should restart the server or kill process using Task manager.

    If you have "connect to pipe" error you should check your sys tem for viruses. It seems that it is infected by Backdoor.HacDef virus family.
    I recommend
    http://download.drweb.com/drweb+cureit/
    for virus checking.
    If you'll get
    Backdoor.HacDef.100
    it will be better to reinstall Windows.
     
Loading...