1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ERROR while trying to check the host name on FC4

Discussion in 'Plesk for Linux - 8.x and Older' started by hq4ever, Apr 30, 2006.

  1. hq4ever

    hq4ever Guest

    0
     
    Hi everyone.
    This is on a fresh install of FC4 after I did yum check-update and yum update.
    Previous install trouble history can be found in this thread http://forum.swsoft.com/showthread.php?threadid=33224
    What could be done ?

    Code:
     Trying to check if xinetd daemon is running... done
    
    ERROR while trying to check the host name
    Check the error reason(see log file: /tmp/psa_8.0.0_FedoraCore_4_build80060331.1
    
    Aborting...
    
    error: %pre(psa-8.0.0-fc4.build80060331.13.i586) scriptlet failed, exit status 1
    error:   install: %pre scriptlet failed (2), skipping psa-8.0.0-fc4.build8006033
    Error while execute command rpm -U /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-4-i3831.13.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-4-i386/base/psa-8.0.0-fc40/dist-rpm-FedoraCore-4-i386/base/psa-api-8.0.0-fc4.build80060413.08.noarch.rpm
    ERROR: error while executing RPM
    ERROR: Installation failed
    
    The host name of the machine is correct. I is set in /etc/hosts and it has an external address that is registed in the DNS server and can be dig'ed.
    The machine is behind a NAT.

    Any help with this `stuff` is much wanted.

    Thank you.
    Maxim.
     
  2. hq4ever

    hq4ever Guest

    0
     
    I'm trying to do a minimalist install to see if that makes any difference

    Code:
    Installation type
    ===============================================================================
    
    Please select the components you wish to install:
    
     1. [*] Base packages of Plesk
     2. [=] Plesk Updater
     3. [ ] Frontpage 2002 support
     4. [ ] Apache ASP support
     5. [ ] Mailman mailing list manager support
     6. [ ] PosgreSQL server support
     7. [ ] Tomcat Java Servlets support
     8. [ ] SpamAssassin support
     9. [ ] SPAM blocker for QMail daemon
    10. [ ] Apache mod_python module
    11. [ ] Application vault packages
    12. [ ] Additional Horde (webmail) components for Plesk
    13. [ ] Additional Plesk manuals
    14. [ ] Backup utilities
    15. [ ] Dr. Web antivirus
    16. [ ] Plesk Professional Web Site Editor
    17. [ ] Plesk API [former Plesk Agent]
    18. [ ] SSHTerm - SSH Terminal java applet
    19. [ ] Plesk migration manager
    20. [ ] Plesk Firewall module
    21. [ ] Plesk Counter-Strike game server module
    22. [ ] Plesk VPN module
    23. [ ] Plesk Battlefield 1942 game server module
    24. [ ] Plesk Battlefield2 game server module
    25. [ ] Plesk Fileserver module and SMB file server package
    26. [ ] Watchdog (System monitoring module)
    27. [ ] SiteBuilder and Sitebuilder module for Plesk
    28. [ ] ColdFusion support for Plesk
    29. [ ] Acronis TrueImage module
    
    N) Next page; P) Go back;  Q) Cancel installing;
    A) Select all; D) Deselect all;
    To toggle component enter its number;
    Type a number or a character of desired action [N]:
    
     
  3. hq4ever

    hq4ever Guest

    0
     
    Same error

    The log doesn't say much either
     
  4. crash

    crash Guest

    0
     
    I'm getting the same error on CentOS 4.2 & plesk 8.0. have you found a work around yet?
    I've tried all kinds of configurations in the /etc/hosts file, noting works.

    It's complaing that the /etc/hosts file does not match the DNS, but it actuall does. Wtf?
     
  5. hq4ever

    hq4ever Guest

    0
     
    At the end I realised that the reason I was getting those errors was because my setup included a NAT between the server and the internet. Plesk doesn't seem to support this. (sad but true).

    HTH
     
  6. crash

    crash Guest

    0
     
    What do you know. I came in and ran the installer this morning and it went through just fine.
    The sw-soft guys must have updated the installer.
     
  7. hq4ever

    hq4ever Guest

    0
     
    So, Can you confirm that Plesk is working behind NAT ?? :eek:
     
  8. crash

    crash Guest

    0
     
    no NAT here. The server I was having problems with had a straight connection to the internet.
    I havent done anything to the server since last night, so the aut o installer script must have been updated.
     
Loading...