• Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

FAIL: ftp per_source_limit from

JuanCar

Regular Pleskian
When I send files to my through FTP, the server cuts connection and I get this message in messages log file

FAIL: ftp per_source_limit from xxx.xxx.xxx.xxx

xxx.... my IP

And I've observed the connection is closed and opened during the transfer.

Which is the cause of this behavior?

I avoid disconnection adding per_source=unlimited in /etc/xinetd.d/ftp_psa
But I see this entry in the same message log

mod_delay/0.7: unable to open DelayTable '/var/proftpd.delay': No such file or directory

Any info about this?
Thanks
 
You have a configuration file called "/etc/xinetd.d/ftp_psa" for PROFTP, which looks like this:

Code:
#ATTENTION!
#
#DO NOT MODIFY THIS FILE BECAUSE IT WAS GENERATED AUTOMATICALLY,
#SO ALL YOUR CHANGES WILL BE LOST AFTER YOU UPGRADE PARALLELS PLESK PANEL.

service ftp
{
   flags       = IPv6
   flags        = IPv4
    disable    = no
    socket_type    = stream
    protocol    = tcp
    wait        = no
    user        = root
    instances    = UNLIMITED
    server        = /usr/sbin/in.proftpd
    server_args    = -c /etc/proftpd.conf
}
Please consider adding "per_source = UNLIMITED" right under "instances = UNLIMITED" and restart xinetd with the command "service xinetd restart", to avoid the described issue.
 
Back
Top