1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Failed dependency upgrading PHP

Discussion in 'Plesk for Linux - 8.x and Older' started by mdafforn, Feb 21, 2010.

  1. mdafforn

    mdafforn New Pleskian

    22
    73%
    Joined:
    Feb 28, 2005
    Messages:
    14
    Likes Received:
    0
    I am trying to upgrade PHP from 4.3.9 to 5.2 using the ART repository (from everything I've read it's supposed to be easy, just do it), but it's failing on a dependency.

    When I try to do a 'yum upgrade php', I get:

    -> Processing Dependency: php-common = 5.2.12-1.el4.art for package: php-xml
    --> Finished Dependency Resolution
    Error: Missing Dependency: php-common = 5.2.12-1.el4.art is needed by package php-xml

    Anyone know how to cure this dependency?

    Anyone know what uses php-xml? I removed the other stuff that sitebuilder used, and was wondering if this was one last thing.

    Thanks!
     
Loading...