1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Failed to open sendmail / Horde not sending emails

Discussion in 'Plesk for Linux - 8.x and Older' started by Mandi, Jul 15, 2007.

  1. Mandi

    Mandi Guest

    0
     
    Hello,
    I just upgraded to Plesk 8.2.0 and I noticed that the Horde is not delivering emails.
    The error is as above and when I check the permissions of the sendmail, they are set just fine:
    -r-xr-xr-x 1 root qmail 9672 Jul 6 02:08 /var/qmail/bin/sendmail

    any idea?
     
  2. Mandi

    Mandi Guest

    0
     
    I had disabled some functions in the PHP from running. These functions are probably run by Horde (new one) and this is prohibiting the deliver of the message!
     
  3. w0uter

    w0uter Guest

    0
     
    I have the same problem. If have disable the follow functions.

    "exec,system,passthru,readfile,shell_exec,escapeshellarg,escapeshellcmd,proc_close,proc_open,ini_alter,dl,popen,parse_ini_file,
    show_source,curl_exec"

    Is there some who knows witch functions horde need ?
     
  4. DerFalk

    DerFalk Guest

    0
     
    try this:
    Code:
    cd /etc/xinetd.d
    /etc/xinetd.d # mv smtp.psa smtp-psa
    /etc/xinetd.d # mv smtps.psa smtps-psa
    /etc/xinetd.d # /etc/init.d/xinetd restart
     
  5. Chris@

    Chris@ Guest

    0
     
    I have this same problem.

    Regarding the above post, I don't have smtp.psa in my /etc/xinet.d folder. I have an smtp_psa and smtps_psa.

    I had to remove popen from my disabled functions in php.ini to fix this problem after upgrading to 8.2.1. Is there a better workaround for this? I read in another thread that selinux had to be disabled, which I did but that didn't fix the problem, only removing popen from my php.ini fixed the problem. This only started after the upgrade.
     
  6. znrak

    znrak Guest

    0
     
    I found that horde will use 'popen' function to open /var/qmail/bin/sendmail.

    And will use 'escapeshellcmd' function to send an e-mail.

    After removed those two functions from 'disable_functions' parameter (/etc/php.ini), horde and mail system will be OK.

    Try it.

    Regards.
     
  7. w0uter

    w0uter Guest

    0
     
    Thx, My webmail works fine again.
     
  8. dasmo

    dasmo Guest

    0
     
    You guys are crazy, you're disabling a security setting to fix a problem? It's just a setting change:
    edit /usr/share/psa-horde/config/conf.php.

    Change the line that says:
    $conf['mailer']['type'] = 'sendmail';

    to

    $conf['mailer']['type'] = 'smtp';
     
  9. znrak

    znrak Guest

    0
     
    Yes, have to say a big thanks to dasmo and very sorry for my carelessly.

    To fix this webmail problem, please follow to dasmo's instruction.

    popen has a risk to your system and dont forget to add it to /etc/php.ini.

    Thank you.
     
  10. DerFalk

    DerFalk Guest

    0
     
    Ok, now which functions should be disabled in the php.ini?
     
  11. znrak

    znrak Guest

    0
     
    For my disabled functions are as following:

    popen, escapeshellcmd, curl_exec, posix_getpwuid, posix_kill, posix_mkfifo, posix_mknod, posix_access, dbmopen, dl, show_source, suexec, exec, pcntl_exec, ini_alter, openlog, escapeshellarg, passthru, proc_open, proc_close, proc_get_status, proc_nice, proc_terminate, shell_exec, system, apache_child_terminate, apache_get_modules, apache_get_version, apache_getenv, apache_lookup_uri, apache_note, apache_request_headers, apache_reset_timeout, apache_response_headers, apache_setenv

    Please select and use it as you need.

    Regards.
     
  12. FrankWoelffel

    FrankWoelffel Guest

    0
     
    What's about Spamfilter

    I have changed the

    $conf['mailer']['type'] = 'sendmail';

    to

    $conf['mailer']['type'] = 'smtp';

    and it works fine, but it seems, that the Spammassasin could not work with this. I Think there must be a few parameters to say Spamassasin to work with smtp. Am I right? And where do I have to change?

    Thx.
     
  13. mfive

    mfive Guest

    0
     
    I'm having the same problem as mentioned above...

    When I change my config.file and the parameter you stated to "smtp", I now get this error from Horde when trying to send emails:

    Error There was an error sending your message: Failed to send data [SMTP: Invalid response code received from server (code: 554, response: mail server permanently rejected message (#5.3.0))]

    Any other suggestions? My problem seems to have come out of nowhere. I didn't make any changes for this to start happening...
     
  14. freeThunder

    freeThunder Guest

    0
     
    simple solution for Invalid response code received from server error it worked for me

    i have the same problem, i tried most of the writen in the forums and with a click i solve the problem.

    i use plesk 7.5 and horde in my server

    -open plesk
    -click the server from the right menu and mail from the services there is a checkbox saying 'Check the passwords for mailboxes in the dictionary'
    -make the checkbox checked.

    but also check the line below from your conf.php. the line must be like this.
    $conf['mailer']['type'] = 'smtp';

    everything is just fine for me

    i hope it helps...
     
  15. charlielove

    charlielove Guest

    0
     
    Security - Disabled SendMail so use SMTP

    Dasmo suggestion is correct:

    but you also need the line:

    $config['mailer']['params']['host'] = 'localhost';

    Restarted Apache and it all works great now!

    Cheers

    Charlie Love
    Drop Design
     
  16. ACID25

    ACID25 Guest

    0
     
    Hi

    i have the same problem now and i tried the the things here from this thread
    change the lines in the conf.php

    $conf['mailer']['params']['host'] = 'localhost';
    $conf['mailer']['type'] = 'smtp';

    but if i now add the "popen, escapeshellcmd," parameter again to "disable_function" horde will not sent emails. Without those to parameters horde sent the mail. But i want to add this option cause of security reasons.
    Any idea what´s wrong ????

    THX and regards
    ACID25
     
  17. mfive

    mfive Guest

    0
     
    Just as a future suggestion to anyone who may have this problem...

    My problem was due to the fact that I also run my SMTP service on port 26 due to ISP restrictions for myself and some of my clients...

    If you are doing this as well, and update plesk or make changes to qmail, you may need to re-establish your smtp on port 25 & 26 again. This fixed my problem both times I did it.
     
Loading...