• The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • Debian 11 has reached its end-of-life (vendor EOL date - August 31, 2026). Plesk Obsidian 18.0.81 is the last release to support it.
    If you are running Plesk Obsidian on Debian 11, we recommend you upgrade those servers to Debian 12 using our dist-upgrade tool.
  • We plan to deprecate and remove the support for XML RPC protocol versions earlier than 1.6.9.1 in Plesk Obsidian 18.0.82. We strongly recommend that you update all existing integrations using earlier versions of the XML RPC protocol to comply with the version 1.6.9.1 specification.

file upload permission

LoïcM

Basic Pleskian
[SOLVED] file upload permission

Hi,
i'm running plesk 10.4 on a ubuntu 8.10 server, i've created vhosts with PHP (fast-cgi).
I' ve a script that upload files to the server and i'm facing permissions issue :

the uploaded files get a 600 permission, that means the psacln group cannot read the file, so i cannot view / download the file via http.

i've check the upload directory, permissions are OK .
I dont know where to search now, is it a suexec issue ? Can we set up UMASK somewhere ?

Any help would be appreciated.

here is the suexec section for that vhost:

<IfModule mod_suexec.c>
SuexecUserGroup "admaxr" "psacln"
</IfModule>

the upload dir :

drwxr-xr-x 5 admaxr psacln 4096 2012-03-07 20:39 files
 
Last edited:
help please

nobody else got that problem ?
this is very annoying, i run a cms for a client and uploaded files cannot be view / edit unless i run chmod 0644
on it.

this is all the error i can see in logfile :

Permission denied: file permissions deny server access: /var/www/vhosts/...

i see other people having this pb on google but cannot find a solution.
 
Back
Top