1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

For gawd sake .. fix the spam assassin please still broken in 7.5.2 ...

Discussion in 'Plesk for Linux - 8.x and Older' started by CBiLL, Feb 2, 2005.

  1. CBiLL

    CBiLL Guest

    0
     
    Come on ... fix the freaking product that you are charging extra for like the damn Spam Assassin ..

    After the upgrade today .. everyone emailing and calling me today saying they getting a thousands of emails marked *****SPAM***** instead of being just deleted that they had it set for ..

    Now I gotta go back and manually set 200 domains emails accounts to make my client happy .. one thing for sure you are NOT making ME happy ...

    Bill
     
  2. CBiLL

    CBiLL Guest

    0
     
    Wow you even made it worse in 7.5.2 ... now I can't even fix it manaully .. And every cleints is calling / IMing / Emailing // using every freaking methods to send me a message .. I bet if I went outside they'll be sending smoke signals ..


    Can anyone fix their spam assassin ?

    If so I would like to know how ..

    I hope they release a patch soon ..

    Sigh ....

    Bill
     
  3. clydetech

    clydetech Guest

    0
     
    Spam assassin broken here too.

    My spamassassin was working fine till the 7.5.2 update now I have had to manually disable it on every mailbox or the users just get blank emails and I get an error in the qmail log.

    " qmail: 1107406633.690064 delivery 154: success: /bin/
    sh:_line_1:_/usr/local/psa/bin/psa-spamc:_cannot_execute_binary_file/did_1+0+2/d
    id_0+0+1/"

    when I say blank i mean every field is blank date, subject, to, from everything. Not impressed.

    how do I fix this?

    regards
     
  4. uhoh

    uhoh Guest

    0
     
    LOL,not laughing at you dude, just laughing at the general situation with this product.
     
  5. jshanley

    jshanley Guest

    0
     
    SpamAssassin Problems

    It's very likely the fault of the upgrader/Plesk, but:

    a) Does /usr/local/psa/bin/psa-spamc exist?
    b) If so, is it executable?
    c) If so, who is the owner/group?
    d) What is the first line of psa-spamc? Does it point to a valid shell? If not, fix that with a symlink for the appropriate shell. I linked bash on FreeBSD to /bin/bash just because lots of plesk stuff points there, even though FreeBSD uses /usr/local/bin/bash or whatever. heh.

    PS: I still say they should sell the FreeBSD version of Plesk at half price until they take it seriously. It's pretty clear to me that they don't test Plesk very often on a clean install at all; they probably test it on a box with all the "extra" perl modules already loaded, and with all the tweaks done, etc. So they never see half the bugs.

    SW-Soft, you guys have money now. Hire someone that KNOWS how to test your software. Just "installing it without getting an error message" is not thoroughly testing your product. *sigh*

    It's sad and unprofessional.
     
  6. clydetech

    clydetech Guest

    0
     
    Re: SpamAssassin Problems

    a) yes the file exists.
    b) Yes it is executable.
    c) root/psaadm
    d) The file is in binary.

    Any ideas.
     
  7. jshanley

    jshanley Guest

    0
     
    I hate to suggest this, but (after backing up the original file), if you replace the new psa-spamc (temporarily) with a version from 7.1.x, does it resume working?

    And, what OS are you using? Hmm, I would presume FreeBSD based on your path structure, nevermind :p What version of FreeBSD?

    -J
     
  8. jshanley

    jshanley Guest

    0
     
    Back up your original.
    Here are the contents of my

    /usr/local/psa/bin/psa-spamc

    ... from 7.1.6/FreeBSD. It's not in binary. I would presume that it hasn't changed much since then, but we'll see. Give it a shot anyway.

    PHP:
    #!/bin/sh

    SPAMC=/usr/local/psa/spamassassin/bin/spamc
    CALL_SPAMC
    ="yes"                                # should spamc run?
    MAX_SIZE=256000                         # max letter size to filter

    "no" = ${CALL_SPAMC} ] && cat - && exit 0

    util
    ="${SPAMC} -s ${MAX_SIZE}"

    until [ -"$1" ]; do util="${util} \"$1\""shiftdone

    eval ${util}
    ... meanwhile, I'll wait to upgrade my FreeBSD system to 7.5 for another few days.


    Plesk Motto: The more things change, the more they stay the same. :eek:
     
  9. clydetech

    clydetech Guest

    0
     
    OK kind of works now i get this message the mail is delivered as it should be

    " spamc[10269]: connect(AF_UNIX) to spamd /tmp/spamd_full.sock failed: No such file or directory/"

    Mail headers show no evidence of the mail having been scanned for spam.
     
  10. jshanley

    jshanley Guest

    0
     
    spamd sock

    do:

    # ps auxwww | grep spamd

    If spamd is running, it'll return some results. If not, that's another issue. OK, if it's running, look for the line:

    --socketpath=/tmp/spamd_full.sock

    ... or something similar. If it points to another location, symlink the new location to /tmp/spamd_full.sock

    If spamd is not running, do:

    /usr/local/psa/rc.d/psa-spamassassin start

    and see what happens with that.
     
  11. clydetech

    clydetech Guest

    0
     
    Ok that seem to be it sorted now.

    Spamassasin was starting instead of psa-spamassassin.

    Thanks for all your help.
     
  12. jshanley

    jshanley Guest

    0
     
    No problem; glad it worked out for you.
     
  13. CBiLL

    CBiLL Guest

    0
     
    Seem I got the spam working for my client again but they still complaining that too many spam than before is coming thur ..

    I checked thier headers and there no spam score marked in the "Delete Spam" but if I set it to mark **SPAM** it will score each email in the header ..

    I think there still problem with score and spam ... I know one client set his score to 3 which is like almost zero spam and he's getting spam if the score was set at 8 or so ..

    I tried to check the headers of the spam the client is getting and nothing is marked in the header of what score the spamd marked allowing the email to pass test and not to be deleted and also no where in the header it tell what score it must pass before it allow in the inbox .. It show all those in the header if you use "Mark Email with ***SPAM***" feature ..

    I do know this was working before the 7.5 and it would show scores in all headers so it broke after the 7.5 and made it worse now in 7.5.2 which the score seem to play no role even if the spamd is working and running and also all the ruleset I have applied are ignored now ..



    in .qmail I am showing

    | /usr/local/psa/bin/psa-spamc -f -u user@domain.com -U /tmp/spamd_light.sock -c || exit 99
    | true
    ./Maildir/



    Also in user_prefs was blank so I added this string in there

    required_hits 3

    But doesn't seem to effect the score in any way .. beside I have no way of telling what score it's using for thier require hits becuase it no longer marking in emails that pass the tests.


    Client does not want to use the "Mark email with **SPAM**" option so I don't have a choice but try to fix this for them .. and have it deleting spam and scoring the ones that did not get delete to see if it scoring correctly .


    Bill
     
  14. jshanley

    jshanley Guest

    0
     
    Hmm. OK, I have heard that the per-user SpamAssassin settings can easily get broken with Plesk as well. See this thread.

    You might want to try:

    /usr/local/psa/admin/sbin/mchk -v

    This "should" rebuild the spamassassin settings files, according to what the database says. If not, well, I dont know. At that point I would just write a script that scans through all the virtual domains & mailboxes and sets them all to "enable spamassassin & delete spam" or whatever, and then it'd be easy to change settings back to "dont delete" for the few clients that want that.

    Warning: Running mchk may disrupt (email) service while it runs. I would hope not, but I'm not sure anymore these days. heh.
     
  15. CBiLL

    CBiLL Guest

    0
     
    I tried the /usr/local/psa/admin/sbin/mchk -v

    Here the output result I got from it ..

    sh: -c: line 1: unexpected EOF while looking for matching `''
    sh: -c: line 2: syntax error: unexpected end of file
    mchk: popen_exec: command failed code: 2 , error: none
    mchk: popen_exec: command failed code: 2 , error: none


    Mean anything to you?

    BIll
     
  16. CBiLL

    CBiLL Guest

    0
     
    It deleting spams but the ones that does't get delete in the inbox have no status report from spam assassin and the score result why it didn't get deleted ..

    It working in one part but the other is broken ..

    Bill
     
  17. jshanley

    jshanley Guest

    0
     
    Well, I'm not exactly sure what happened there. mchk (or something that it called) was parsing either a db file or a text file, and it expected the input to be inside quotes, like this:

    `it was expecting text inside quotes like this`

    but it got something like this

    `this text has a start quote but no end quote

    Now, I dont know what exactly its parsing here when it breaks (maybe a .qmail file, not sure). Perhaps someone else would be able to track this down, or SWSoft themselves. Man, with all these issues people are having, I'm really scared to upgrade to 7.5.2. If it wasn't for the new "drop bad email addresses by default" and the bigger application vault that users want, I would probably not upgrade at all. *sigh*

    Also, I wonder why they are not using SpamAssassin 3 now (or are they with 7.5?) It is -soooo- much more effective than the 2.x series.

    -J
     
  18. squalo

    squalo New Pleskian

    22
    73%
    Joined:
    Oct 7, 2004
    Messages:
    17
    Likes Received:
    0
    after upgrade

    rpmdb: fatal region error detected; run recovery
    error: db4 error(-30982) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
    error: cannot open Packages index using db3 - (-30982)
    mchk: Unable to open rpm db: cannot open Packages index using db3 - (-30982)


    System error 2: No such file or directory
    mchk: Unable to open rpm db: cannot open Packages index using db3 - (-30982)


    System error 2: No such file or directory

    kan my help? :confused:
     
  19. jshanley

    jshanley Guest

    0
     
    Your RPM package database is damaged or gone. But that has nothing to do with this thread at all.
     
  20. uhoh

    uhoh Guest

    0
     
    so then will this be a problem on a freebsd machine?
     
Loading...