1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Fresh install with a few issues

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by thelongmile, Apr 14, 2011.

  1. thelongmile

    thelongmile Guest

    0
     
    Hello!

    I'm very new to the world of plesk so I hope you'll help me out with a few problems I've been having.

    I've installed Plesk Panel 10.2.0 onto a Clean install of Centos 5.6 x86_64, and I've encountered a couple of issues post installation, This was a 'typical' install rather than a 'complete' one..

    The server currently has no domains added to it and is a completely clean installation...

    1) Mail from the server isn't sending at all, previously I've installed servers with no domains but a valid hostname (in my case DS142.redstation.com or similar) and the phpmailer has sent mail from that with no issues. I note that this is using qmail, so I ran tail -f /usr/local/psa/var/log/maillog and got the following

    Just so you know, I've hidden the email address on this cut and paste as I don't really want to give that out! but it is a valid mail address!

    I was under the impression that Plesk automatically configured and set up mail on installation?

    2: Like a dope I installed the 'typical' installation rather than the complete one, how does one go about adding the modules? (I really pray that isn't a reinstall, not really an option as something is going live in a few hours!) (like server health, I forgot to install that)

    3: Wordpress - I thought I'd try this out on a test domain I set up and sure enough wordpress has massive issues , as does joomla etc. Script creation, file uploading, even the age old 'asking for ftp' information again (even hard coding it doesn't seem to help), tried sexy bookmarks etc and got a lot of write error issues...... the only way I could get wordpress to run 'right' was the chown the entire directory recursively as root:root. I had a limited amount of success adding the psacln and psasrv to the apache group but I still had errors.

    I cannot use sitebuilder, I'm not licensed for it, plus people like to install their own. Using CHOWN everytime I get a customer isn't really an option... Is there something I'm missing here?

    4: Connecting to external SQL databases doesn't seem to work, my plesk servers IP is 109.73.99.99 and the IP address of the other server is 109.168.99.99 and has the external ports set up for remote SQL. Whenever I try to add the server to Plesk, it seems that Plesk tries to authenticate using it's IP for the username, rather than the one on the other machine, and it fails, with the following error message
    Is it supposed to be trying to authenticate with username@pleskserverip rather than username@remotesqlserverip ?

    (just so you know, IP addresses changed for security)

    Other than these things, I'm quite enjoying plesk so far and if I'm able to get these sorted out, I'll probably be looking at upgrading my licence.

    Any help, is very, very much appreciated!
     
    Last edited by a moderator: Apr 14, 2011
  2. thelongmile

    thelongmile Guest

    0
     
    Just to add, I've done a clean reinstall of this now with zero change whatsoever, even configured a customer on there, with no success... any help at all on the mail issue alone will be very much appreciated!
     
  3. thelongmile

    thelongmile Guest

    0
     
    Ok, some more information for you,

    I ran the following, /var/qmail/bin/qmail-showctl

    And got the following

    So, some more information for mail!

    Hopefully this is going to benefit someone for me finally getting a response!
     
  4. thelongmile

    thelongmile Guest

    0
     
    Interesting, I don't have any SSL certificates... wonder why that is... this is about as vanilla as it gets...
     
  5. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    Hello, thelongmile.

    Seems the client couldn't send the mail to remote server. You can see the following error message in maillog:
    Sorry,_I_wasn't_able_to_establish_an_SMTP_connection._(#4.4.1)

    It indicates the problems with remote SMTP server. Maybe port 25 is closed by firewall or wrong remote SMTP server.
    For example, GoDaddy has SMTP port closed by default and requires to specify their own SMTP gateway.
    In this case you should ask provider's support about correct SMTP gateway and edit a config file /var/qmail/control/smtproutes.
     
  6. thelongmile

    thelongmile Guest

    0
     
    Hello

    Thanks for your response. I own the server, and I am the provider and the network that it's on has no blocked ports at all. I've not had any prompts anywhere on the installation to set up anything, nor have I actually set up an SMTP server, or told it to look elsewhere. This is a plain, Vanilla installation, so I don't see what is going on here.

    Can you please advise further?
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
Loading...