1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

FTP broken...

Discussion in 'Plesk for Windows - 8.x and Older' started by gljiva, Feb 20, 2005.

  1. gljiva

    gljiva Guest

    0
     
    Hi all,

    no client can connect to FTP:

    530 User acme cannot log in, home directory inaccessible.

    (server FQDN name is 12 characters long)
    manuly checked proprerties - same error
    plesk reconfigurator - same error
    repair installation - same error
    reinstalled ftp & plesk - same error
    wiped out all - reistall all - same error

    also,

    server has 1 private IP address and is behind hardware NAT/PAT firewall. DNS FTP record points to public IP address. However, Plesk add public IP address on ftp server listener?????

    Any idea... (I have re-read all forum about similar cases, but no help....)

    Thanks

    Gljiva
     
  2. gmoody

    gmoody Guest

    0
     
    I too am unable to ftp to the domains on a new 7.5 install. In the interest of helping those that visit the board I will post any support tickets that I send to Plesk and the replies that I receive. I have submitted a support ticket regarding this problem. The actual support ticket is as follows:
    <--Support Ticket

    Brand New Server. Fresh install of windows 2003. Followed installation manual from Plesk website.
    1) Installed Plesk 7.5
    2) Installed Key
    3) rebooted server
    4) installed clamav_win
    5) installed mailenable professional
    6) set clamav and mailenable pro and MEwebmail as defaults through Plesk control panel components section.
    7) restarted all plesk services
    8) logged on to the control panel and created a new client on the shared ip address
    9) created a new domain for the client as foillows:

    Set username and password
    Login disabled
    Frontpage disabled
    ASP, ASP.net, PHP, AWSTATS - enabled

    Tried to FTP to site using: domain name, ftp.domain name and www.domain name. I get error 530 login incorrect.

    Tried resetting password through control panel - No luck
    Tried resetting username and password through contol panel - no luck

    I am unable to FTP into the account.

    Plesk Support WILL NOT get access to my servers, so you will need to trouble shoot from the information provided.

    Support Ticket-->

    I will post the response from Plesk support.
     
  3. flyby

    flyby Guest

    0
     
    I got the same problem, and i check all premission. and everthing.

    But i fixed it by:
    In the ms ftp server for that IP, i find the home dir:

    c:\inetpub\vhosts\servers\12415\
    c:\inetpub\vhosts\servers\12415\localuser\xxxxxxx

    And then under localuser i did not find the nave on the user.
    There was others, and thows ftp was working.

    I made a folde whit the name of the user (not domain), under premission i add the user. And removed the fedault msftpXXX user there was made.

    Then i copy all from root folder from the domain over to the "root" of the site under ftp folder.
    c:\inetpub\vhosts\domain
    c:\inetpub\vhosts\servers\12415\localuser\xxxxxxx

    I then turn on anonymes ftp, and off again after 3 min.

    And it did not work for awhile, but when the clock was 7 PM my smartFtp client got on ( it try every 30 sek).. well cal me crazy, but it was woring.. I think that is a Scheduler task that runs every hour.


    Right at the same time i got a strange fine in my root dir.
    at_domains_index.html
     
  4. flyby

    flyby Guest

    0
     
    the file
     
  5. gljiva

    gljiva Guest

    0
     
    I found that if A record in DNS template is diferent from <ip>, ftp have problems...

    to fix it run:

    "C:\Program Files\SWsoft\Plesk\admin\bin\"ftpmng --reconfigure-all

    (let me know does this works for you)
     
  6. flyby

    flyby Guest

    0
     
    Me too!
    I have set up the default DNS template whit my public IP and then plesk set up a FTP server on this IP. And it makes problems whit FTP connections error 530.
    I run reconfig tool whit everything. It removed the FTP server whit public Ip and then all my FTP site workd. But after some time (6 hours) the FTP server whit my public IP was back!!!!

    NB: Ohh one more thing. When i used my Reconfig tool, i lost some of my MySQL databases! !!!!!!!!!

    But beside this I thing the new 7.5 runs fine when compare whit all the 7.0.x versions.
     
  7. henry@

    henry@ Guest

    0
     
    FTP

    Testing....
     
  8. oven

    oven Guest

    0
     
    I use two following commands for fix this problem:

    ftpmng --remove-all
    ftpmng --reconfigure-all

    It will help you.
     
  9. flyby

    flyby Guest

    0
     
    Cool thanks I try it next time ;)
     
  10. nathand

    nathand Guest

    0
     
    I'm still having problems with FTP after an upgrade from 7.0.2 to 7.5.1. Just noticed this post. Could someone explain what this does?

    Thanks!

     
  11. nathand

    nathand Guest

    0
     
    Jeepers Batman it WORKED!!!

    I have no clue what i did but I did the two commands above and BAM! FTP is back up!

    Thanks!!! :D

    Nathan
     
Loading...