1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FTP Login Access Error

Discussion in 'Plesk for Windows - 8.x and Older' started by croosie, May 12, 2005.

  1. croosie

    croosie Guest

    0
     
    hi ,
    Please can you help,
    I'm new to plesk, and have just created a domain, and am now trying to connect to FTP.
    I keep getting the following error ....

    STATUS:> Getting listing "/"...
    STATUS:> Resolving host name ftp.domain.co.za...
    STATUS:> Host name ftp.domain.co.za resolved: ip = 216.*.*.* STATUS:> Connecting to FTP server ftp.domain.co.za:21 (ip = 216.*.*.*)...
    STATUS:> Socket connected. Waiting for welcome message...
    220 Microsoft FTP Service
    STATUS:> Connected. Authenticating...
    COMMAND:> USER username
    331 Password required for username.
    COMMAND:> PASS *****
    530 User username cannot log in, home directory inaccessible.
    ERROR:> Not logged in.
    STATUS:> Connection closed.


    PLEASE HElP,

    THanks

    Kirwin
     
  2. Kihot

    Kihot Guest

    0
     
    Hi Kirwin,

    Right click on the FTP Sites in MMC and choose Help. Then go: Internet Information Services -> Server Administration -> FTP Site Administration.
    Read carefully how to set up a FTP site.

    Make sure to set NTFS permissions on the home folders.

    Hope that helps.
     
  3. orkunerbil

    orkunerbil Basic Pleskian

    23
    23%
    Joined:
    Jan 15, 2004
    Messages:
    28
    Likes Received:
    0
    Very stupid but, I have tried nearly everything, even deleting and re adding the site did not work.
    Than I added a domain with different name and changed its name from preferences to the first domain, and it worked.

    Plesk is improving our creativity each day.
     
  4. robtbs

    robtbs Guest

    0
     
    orkunerbil: i was experiencing the same error....

    It can be to do with IIS default site location...
    select the FTP site... (listed by IPs)

    get the properties up and check the home DIR is set to ...

    C:\inetpub\vhosts\server\{number}

    -------------------------

    The actual thing that fixed my issue was a stupid user error...
    :)

    you have to access the site by FTP using the ip address in its IP Pool,
    so if like me you have loads of IP addresses,

    so.... domain1.com = 212.44.35.122
    and domain2.com = 212.44.35.123

    in the above.. if you access domain2.com via 212.44.35.122 even though it points to the same server... it will return the home directory inaccessable error,

    The FTP files for each IP address is stored seperatly under a different numbered folder in ..
    C:\inetpub\vhosts\servers

    FYI :D

    Rob
    www.masterserver.co.uk
     
  5. mikelegg

    mikelegg Guest

    0
     
    I was able to fix this problem more simply. In my case Plesk had failed to give IUSR_domain read/write permissions on the httpdocs folder. When I added them everything was OK.
     
  6. Livewire

    Livewire Guest

    0
     
    hi all, having a simular problem that is affecting ftp server wide, whenever someone trys to log in they get point blank refused; in the server logs this appears:

    User rxie failed to log on, could not access the home directory /.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    Anyone any ideas ?

    Im running:

    Windows Server 2003 Standard Edition
    Plesk 7.5.4
     
  7. kami@

    kami@ Guest

    0
     
    Would you mind telling us exactly step by step how you fixed this problem??
    I mean how do I get to this IUSR_domain so I can change the permission??

    Thanks
     
  8. mikelegg

    mikelegg Guest

    0
     
    1) Using Remote Desktop (or something similar) log into your server as administrator.

    2) Using Windows Explorer go to C:\Inetpub\vhosts\domainname/httpdocs/

    3) Right click the folder name, select properties.

    4) Click the security tab, make sure that Plesk IIS User (servername/IUSR_ ftploginnane) has "List Folder Contents" ticked in the "Allow" column.

    If this still doesn't work, try adding "Read" and "Write" as well.
     
  9. Traged1

    Traged1 Guest

    0
     
    I have also noticed that sometimes the ftp login fails due to the fact that the domain has Frontpage set to "Enabled", disabling frontpage for the domain allows the ftp login to work properly.

    Also, sometimes the IP's get mixed up, to solve it, add a dedicated/exclusive IP to the domain switch the domain to the new IP, then switch it back to the original IP right afterwords. Restart both FTP and IIS services and your ftp login should work.

    But why does this happen in the first place?
     
  10. addstravel

    addstravel Guest

    0
     
    I have been experiencing the same problems. After navigating to the following FTP folder:

    D:\Websites\vhosts\default\{plesk install}\localuser

    There was no user FTP folder! Once I placed the user folder and the usual website folders (for example, anon_ftp, httpdocs etc) I can access FTP!!!

    Why does this happen?

    * Just discovered that although I can access it I CANNOT add/delete/modify the contents, so back to the drawing board! Why arent new hosting accounts being created with an FTP account so I can upload content for clients accounts? This is terrible......

    I would install the new update as I am using 7.5.4 but am worried about causing more problems! :(
     
  11. paul.fisher

    paul.fisher Guest

    0
     
    I am getting the same problem. I have read through this post and its given me a better idea of what is going on.

    I can see that there are three locations of the users folder structure.

    C:\Inetpub\vhosts\default\4601\{userfolder}
    C:\Inetpub\vhosts\Servers\4601\localuser\{userfolder}
    C:\Inetpub\vhosts\domain.com\httpdocs

    to start with my problem is that plesk isn't creating the permissions correctly on C:\Inetpub\vhosts\default\4601\user folder. Once i have fixed that then the user can log into FTP correctly and upload files etc. The problem I now have is that on other FTP user accounts that work correctly plesk must copy the file(s) to the other two locations. This doesn't seem to be happening.

    Can anyone spread any light on this?

    Thanks
     
  12. mikelegg

    mikelegg Guest

    0
     
    We haven't had this problem since we did the following -
    (1) upgraded to 7.5.6
    (2) made sure we had all of the latest patches installed
    (3) ran Start>>Programs>>SW-Soft>>Plesk>>Plesk Configurator and selected the "Correct disk permissions " option. (a couple of times)
     
  13. curra

    curra Guest

    0
     
    hi

    i have exactly the same problem and tried everythin mentoied here, but it still dont work...any help is appciated :-/

    greetz
    curra
     
  14. curra

    curra Guest

    0
     
    no one out there??

    i tried everything here in the topic and in the knowledgebase :-//
     
  15. dinfiesta

    dinfiesta Guest

    0
     
    I´m my case...the user was locked Out in Windows.

    Any idea why this happened?

    Thanks
     
  16. bmccrindle

    bmccrindle Guest

    0
     
    Has anyone figured this out???

    This is a real pain in the butt. Am running Windows Server 2003 and Plesk 7.5.6, all patches and service packs applied. Have tried all of the "tricks" and workarounds listed in this forum. Where is SW-Soft on this issue?

    Is there another way to provide ftp service for my domain clients? I've seen Serv-U ftp mentioned. Is anybody using it? Does it get us past this major bug in the plesk software?

    Any help/advice much appreciated. :(
     
  17. sd1sd1

    sd1sd1 Guest

    0
     
    Same problem here - it started only when i upgareded to 7.5.6 - and from a reason i don't understand it's only affect accounts that i ctreate after the upgrade. all accounts that was created before the upgrade works perrfectly.
     
  18. thewebmaster

    thewebmaster Guest

    0
     
    Try Following commnads:

    "%plesk_bin%\ftpmng.exe" --remove-all

    "%plesk_bin%\ftpmng.exe" --reconfigure-all

    Hope this will help you guys to access home directory.
     
  19. JustinK101

    JustinK101 Guest

    0
     
    thewebmaster

    THANK YOU FOR ACTUALLY HELPING, unlike support.

    I could not figure out my ftp problem. I was pulling my hair out. Then, I ran the commands you suggested and FTP is working perfectly. Thanks much! You do man!
     
  20. curra

    curra Guest

    0
     
    damn damn damn....driving into nuts here....

    i tried that now 100 times with remove-all and reconfigure-all

    but nothing happens.

    every single ftp account have the same error, even the new created ones.

    anybody can light my head? :-((((

    Plesk 7.5.6 on Virtuozzo here....

    Plesk Plesk for Windows 7.5.6

    Antivirus DrWeb 4.33.0.10050, last update: 16.07.2006, known viruses' signatures: 130159

    Backup-System
    ColdFusion
    SQL-Server
    DNS-Server BIND DNS Server 9.2.4

    Firewall Windows Firewall Service Pack 1

    FTP-Server Microsoft FTP Server 6.0

    Java
    Mailserver MailEnable Standard 1.9

    Netzwerkbetrieb
    Plesk Agent Plesk Agent 1.4.0.0

    Web-Scripting ASP 6.0.3790.1830
    ASP.NET 1.1.4322.0
    Perl v5.8.6 built for MSWin32-x86-multi-thread
    PHP 4.3.11 (cgi-fcgi) (built: Mar 30 2005 17:34:09)
    SSI 6.0.3790.1830

    SiteBuilder Windows SiteBuilder 1.2.0

    Spamfilter SpamAssassin 2.64

    SQL Web Admin ASP.NET Enterprise Manager 0.1.3
    phpMyAdmin 2.6.0-pl3

    Webstatistiken AWStats 6.3 (build 1.800)
    Webalizer V2.01-10-RB02 (Windows NT 5.2 Service Pack 1) English

    Stunnel stunnel 4.07

    Webmail Horde IMP H3 (4.0.1)

    Webveröffentlichung Microsoft FrontPage 5.0.2.6738

    Webserver Microsoft IIS 6.0
     
Loading...