1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FTP Problem - Command not found!

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Oras, Jan 27, 2009.

  1. Oras

    Oras Guest

    0
     
    Hello,
    I installed Plesk 9 yesterday, everything work great except FTP. I tried first to log using FileZilla but it couldn't find the host. I logged using SSH and typed: FTP ... result: Command not found!
    Any help about this please?
    Regards
     
  2. steogede

    steogede Guest

    0
     
    I doubt you are likely to find a command called 'FTP' perhaps 'ftp', but that is an ftp client program (Filezilla) and won't help you with your FTP server woes except in testing your FTP connection.

    I would be happy to try offer some assistance, but it is difficult without more information than 'FileZilla couldn't find host'. There are many things that could be going wrong, you may have typed the wrong server name, there may be a firewall (on the client or the server or somewhere in between) which is blocking the connection (this is where SSHing in and running 'ftp' can be useful for testing), the server may not be running (i.e. the FTP service, or more precisely xinetd might not be starting it when requested).

    So my advice to you would be to SSH in and try running 'ftp', if you still get 'command not found', then install an FTP client (either a basic ftp or something more featuresome, such as ncftp or lftp). If it connects locally but no remotely that would probably indicate a firewall problem. Also useful would be if you gave us details of what operating system/distribution you are running plesk on. If you report back here with some more info, then some on can help.

    On final thing, it would be nice to know what you are using FTP for. Anonymous FTP is alright, but I personally wouldn't advise using FTP for anything else if you can avoid it. If you just want to transfer some files, I would suggest using SFTP/SCP (SSH File Transfer Protocol) - WinSCP is a good client if you are using Windows.
     
  3. Oras

    Oras Guest

    0
     
    Thank you steogede for your reply.
    After submitting my thread, I tried using sftp and it worked for user (root).
    Here is more details about my problem:
    1. OS: Centos 5.2
    2. Plesk 9.
    3. I installed plesk using web interface.

    I tried ftp now and its working!! the only thing I may think of is the license , when I tested the ftp I was working with default demo license, after uploading the key and made an update to plesk it is working now.

    Thank you for your help.
     
  4. Amin Taheri

    Amin Taheri Golden Pleskian Plesk Certified Professional

    33
     
    Joined:
    Jul 5, 2007
    Messages:
    1,398
    Likes Received:
    1
    Location:
    Seattle Area
    not being able to find the host is typically a dns issue.
     
  5. Ted Tucker

    Ted Tucker Guest

    0
     
    I am having a similar problem.. did you ever solve this?
     
Loading...