1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

"Hide News Feeds" not working

Discussion in 'Plesk for Linux - 8.x and Older' started by artm, Jan 5, 2007.

  1. artm

    artm Guest

    0
     
    Plesk finally seemed to have delivered on a fix for their much-hated Plesk newsfeed feature. I got the latest patches using "Updater", and, lo!, there was a server-wide option called "hide newsfeeds" (server >> interface management >> interface templates >> preferences)

    Great!

    So I quickly ticked the box, and... no difference :mad:

    I created a new domain, logged on as user, and there was the unwanted news feature still there!

    Am I doing something wrong, missing something, or is it just buggy software?
     
  2. NorthLANs

    NorthLANs Guest

    0
     
    Artm,

    I had the same problem, but I found a fix. I followed the instructions that I found on another thread.

    edit file /usr/share/psa-horde/templates/portal/sidebar.inc

    go to line 102 and comment it out

    /**
    if (window.NewsFeeds) {
    window.NFopen = (readCookie('plesk_newsfeed_visible') == 'false') ? false : true;
    document.write('<div id="NFcontent" class="sidebarPanel ' + (NFopen ? 'NFopen' : 'NFclose') +'">');
    document.write('<table cellspacing="0" cellpadding="" width="100%" border="0" class="sidebarHeader"><tbody>');
    document.write('<tr>');
    document.write('<td class="headerTitle"><?php echo _('Top News'); ?></td>');
    document.write('<td class="headerButtons"><a href="javascript:NFgetList();" class="btn-refresh" title="<?php echo _('Refresh'); ?$
    document.write('</tr>');
    document.write('</tbody></table>');
    document.write('<div id="newsFeeds"></div>');
    document.write('</div>');
    if (window.NFopen && readCookie('horde_sidebar_expanded') != 'false')
    NFgetList();
    }
    **/

    Hope that helps.
    NorthLANs
     
  3. madsere

    madsere Regular Pleskian

    26
    57%
    Joined:
    May 8, 2005
    Messages:
    200
    Likes Received:
    0
    If you're on Virtuozzo you can fix it for all sites in one go by editing /vz/template/psa-as4/psa-horde-3.1.3-rhel4.build81061129.22/usr/share/psa-horde/templates/portal/sidebar.inc

    (same change as above).

    To activate remember to restart PSA in each VE.
     
  4. nars

    nars Guest

    0
     
    I have noticed same problem... this new option seems to do nothing at all... :(
     
  5. madsere

    madsere Regular Pleskian

    26
    57%
    Joined:
    May 8, 2005
    Messages:
    200
    Likes Received:
    0
    Actually this "news feed" pops up many places, in the place holder pages, in Horde, on admin pages in one or another form. Digging around in the Plesk code it appears that it always starts by checking the value of window.NewsFeeds as in the line

    if (window.NewsFeeds) {

    The cleanest solution would be to find out where windows.Newsfeeds has been set to true and set it to false - or in case that has been done in one of Plesk's conveniently encrypted pages, just plain overriding the value to false ...
     
  6. artm

    artm Guest

    0
     
    Thank you Madsere & NorthLANs for the tips.

    I am reluctant to mess with the guts of Plesk. I wonder if that might not create cascading problems! I may have to give it a go though...

    As for "the cleanest solution" - I guess that would be for SwSoft to stop messing around and
    • quit pumping spam advertising through the control panels
    • if they do publish a fix, have the competence (or intention) to make sure it works
    I guess a cynic might say they are not going to be bothered if their "disable Plesk spam advertising" feature doesn't work?
     
  7. madsere

    madsere Regular Pleskian

    26
    57%
    Joined:
    May 8, 2005
    Messages:
    200
    Likes Received:
    0
    That goes without saying, but it was already made clear in another thread that the inclusion of this spam in Plesk was decided on the top exec level and was not going to be changed.

    I think it's outrageous but am sufficiently tied in with Virtuozzo/Plesk that it would mean considerable work to move to a different platform. That's not to say it won't happen but I'll try getting around the problems first.
     
  8. fisherfrontier@

    fisherfrontier@ Guest

    0
     
    I also tried the "Hide Plesk news" option under Server / Interface Management / Interface Templates / Preferences -- but to no avail.

    Figured out my own override hack with two lines of CSS.

    First, you'll need to be able to edit the "desktop.css" file in whatever Plesk skin(s) you are using.

    So, for example, you could edit this file:
    Code:
    /usr/local/psa/admin/htdocs/skins/winxp.new.compact/css/main/desktop.css
    At the end of the file, simply enter these two lines:
    Code:
    #dBox-news_articles
    { display: none !important; }
    Works like a charm.
     
  9. pfellner

    pfellner Guest

    0
     
    THANK YOU!!!!

    You are a CSS genius! Good call. Thank you!
     
  10. raaqi

    raaqi Guest

    0
     
    MAGIC! Thank you for the css.
     
  11. topnetwork

    topnetwork Guest

    0
     
    A Must Archive Contribution

    I have been looking all over for the right way to disable Plesk News for all desktops or individual desktops: a flag in the interface preferences. But, no. That would have been givving the customer what they want, control over their work environment and an advert free work space.

    Thank you for your contribution. I have archived it offline so that I can return to it after the desktop skins get overwritten with the next Plesk update.
     
Loading...