1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Horde / IMP webmail gone crazy

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Scoffer, Nov 21, 2012.

  1. Scoffer

    Scoffer New Pleskian

    10
     
    Joined:
    Nov 21, 2012
    Messages:
    2
    Likes Received:
    0
    Hi.

    We are hosting over 600 domains on our Plesk installation that has just gone crazy. The current version of the panel is 10.4.4 Update #47, last updated at Nov 1.
    Server is running with Ubuntu Lucid 10.04, 64bit.

    The problem is, Horde webmail stopped working properly yesterday. It usually lets user log in, sometimes showing mailbox and sometimes it not. After couple of seconds or even a minute it throws user out saying password was wrong.

    I've been investigating the problem for some time and psa-horde.log says it's not able to connect to imap:
    Nov 01 16:04:00 HORDE [error] [imp] FAILED LOGIN for name@domain.com [xxx.xxx.xxx.xxx] to {127.0.0.1:143 [imap/notls]} [pid 31057 on line 139 of
    "/usr/share/psa-horde/imp/lib/Auth/imp.php"]

    Same error messages can be found for long time, probably inserting wrong password gets them too. But now I get tons of them.

    telnetting the imap server works always, so does using desktop imap clients and roundcube webmail.

    Some system info:
    uname -a
    Linux [hostname] 2.6.32-41-server #88-Ubuntu SMP Thu Mar 29 14:32:47 UTC 2012 x86_64 GNU/Linux

    php -v
    PHP Warning: Directive 'safe_mode' is deprecated in PHP 5.3 and greater in Unknown on line 0
    PHP 5.3.2-1ubuntu4.18 with Suhosin-Patch (cli) (built: Sep 12 2012 19:12:47)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
    with the ionCube PHP Loader v4.0.7, Copyright (c) 2002-2011, by ionCube Ltd.

    Installed package versions:
    ii psa-horde 3.3.10-ubuntu10.04.build1013111101.14 The Horde framework adopted for Parallels Pa
    ii psa-imp 4.3.9-ubuntu10.04.build1013111101.14 Web Based IMAP Mail Program for Parallels Pa
    ii psa-courier-imap 3.0.8-ubuntu10.04.build1013111101.14 Courier-IMAP v3.0.8 IMAP server

    ulimit -n
    9000

    /etc/security/limits.conf
    * hard nofile 65536
    * soft nofile 65536
    root hard nofile 65536
    root soft nofile 65536
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
  3. Scoffer

    Scoffer New Pleskian

    10
     
    Joined:
    Nov 21, 2012
    Messages:
    2
    Likes Received:
    0
    Hi.

    Thanks for the suggestions, but I've already gone thru that list. There was some things, but didn't seem to make difference.

    1) Works
    2) sessions.save_path isn't specified on php.ini but that just makes it use default directory that is working. And besides, I have "$conf['session']['use_only_cookies'] = true;" on horde configs.
    3) This was my main concern but I don't yet use 1024 FD's. Only 1019. I also grew up allowed FD's at /etc/security/limits.conf by adding following lines:
    * hard nofile 65536
    * soft nofile 65536
    root hard nofile 65536
    root soft nofile 65536

    4) All packages are up to date.
    5) All ok

    Just to be sure, I just enabled piped logs for apache, hoping it would make the difference.
     
  4. SebastianVi

    SebastianVi New Pleskian

    6
     
    Joined:
    Mar 27, 2013
    Messages:
    1
    Likes Received:
    0
    Hi Scoffer,

    did you have any Luck with finding a Solution?
    I have similar Problems, so any information would be of great Help!
     
Loading...