1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Host name for mysql ???

Discussion in 'Plesk for Linux - 8.x and Older' started by tnobs, Nov 30, 2007.

  1. tnobs

    tnobs Guest

    0
     
    Hi

    I want to store weather data form a weather station in my mysql database on the server. The weather software (weather display) tries to connect to the mysql databse, without any success.

    It tells me:
    Unknown mysql server host

    What do I have to type in for hostname:
    is that just the domain, where I setup the database?

    host: ????
    user: xxxx
    password: xxxx
    database_name: xxxx
    table: xxxx

    thanks, tnobs
     
  2. ACID25

    ACID25 Guest

    0
     
    hostname for mysql is "localhost"
     
  3. tnobs

    tnobs Guest

    0
     
    from outside..

    I try to connect from a other server, so I need the full path...


    tnobs
     
  4. corman420

    corman420 Guest

    0
     
    Try the main IP address of the server. And you may also need to turn on the option to allow remote connections to the database.
     
  5. tnobs

    tnobs Guest

    0
     
    Where can I find it?


    I was looking into that, I found a threat about it, but maybe it's easier than that !?
    http://kb.swsoft.com/en/1134

    thanks, Norbert
     
  6. corman420

    corman420 Guest

    0
     
    I always thought there was a way to do it within the plesk cp, but perhaps that was before plesk 8.

    That looks about right. Give it a shot and let us know.
     
  7. tnobs

    tnobs Guest

    0
     
    oje

    First I tried to use the IP for the host name, didn't work.

    I opened the file
    /etc/mysql/my.cnf


    I was looking for the:
    # bind-address = 10.10.0.1
    # skip-networking

    I found the bind-address line, but the skip-networking isn't there. Instead it says:
    skip-external-locking

    For me, it would be logical to not disable this line, since it says skip locking or?

    I'm definitly not a pro on linux, and I don't want to screw the server. Maybe someone can tell me what to do?

    Tnobs
     
Loading...