1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How to enable language(utf8) support for proftpd?

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by GiorgosI, Nov 8, 2012.

  1. GiorgosI

    GiorgosI Basic Pleskian

    21
    73%
    Joined:
    Nov 6, 2009
    Messages:
    64
    Likes Received:
    3
    Plesk 9.5.4, CentOS 5.6 x86_64

    When someone uploads files with greek names through ftp, the uploaded filenames are altered to questionmarks, for example ?????????.jpg and they cannot be browsed.
    If we upload the same file from Plesk's File Manager, it is not altered to questionmarks and can be browsed.

    The version of the proftpd is:
    I found that proftpd needs the mod_lang module enabled in order to be able to handle utf8 characters:
    http://www.proftpd.org/docs/modules/mod_lang.html
    This module is not enabled with proftpd coming with Plesk (the '-' below means it is not enalbed):
    Is there any way to enable language module for proftpd?
     
Loading...