1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How to install mcrypt

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by Deoxymono, Jun 10, 2011.

  1. Deoxymono

    Deoxymono New Pleskian

    13
    60%
    Joined:
    Jun 10, 2011
    Messages:
    14
    Likes Received:
    0
    Hi, I want to run magento on a VPS just purchased. However running the magento compatibility checks reveals 1 error which is: "You are missing the mcrypt extension"

    I've tried and tried to get mcrypt installed but to no avail :(

    Server info: VPS server, Linux 2.6.18-028stab079.1, CentOS 5.6, Parallels Plesk 10.2.0, PHP 5.2.10, MySQL 5.0.77

    N.B I am a relative newbie to SSH and server administration outside of using Cpanel/WHM

    OK after googling the 1st thing I came across was using yum to install mcrypt:

    Steps I followed were:

    1. Type "yum install mcrypt*". Say yes to the prompts.
    2. Type "yum install mhash*". Say yes to the prompts.
    3. Type "yum install php-mcrypt*". Say yes to the prompts.
    4. Type "yum install php-mhash*". Say yes to the prompts.
    5. Restart server

    All steps seemed successful apart from step 1: "yum install mcrypt*"

    Which gives me message 'No package mcrypt available'

    So I decided to try installing it manually, I downloaded the mcrypt 2.6.4 files, unzipped and uploaded with WinSCP to a folder named mcrypt in the root of my server. Then I:

    1. cd to mcrypt directory
    2. typed ./configure
    3. It returns error 'no acceptable C compliler found in $PATH'

    Ok after more googling it seems I need to install a compiler GCC seems to be what everyone uses.

    So my next steps are:

    1. yum install gcc
    2. which returns another error: 'Missing Dependency: kernel-headers >= 2.2.1 is needed by package glibc-headers-2.5-58.el5_6.3.x86_64 (updates)'

    I'm not really sure what that means but I think it seems to be saying gcc needs an older or equal to version of kernel headers 2.2.1 but I have a newer version?

    Well that is about as much as I know what to do, I'm completely stumped now and don't know how to move forward with this :( The annoying thing is I know in Cpanel/WHM you can install mcrypt with a couple of clicks through WHM>easyapache. I wish plesk had this feature.

    Does anyone have any ideas how I can install mcrypt or fix the issues above so I can install gcc? I would be very grateful as I feel like banging my head against a brick wall at the moment!
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,543
    Likes Received:
    1,240
    Location:
    Novosibirsk, Russia
    Did you try to use search on this forum? This question has been discussed a lot of times here. There was solution from atomicturtle.
     
  3. eugenevdm

    eugenevdm Silver Pleskian

    30
    68%
    Joined:
    Nov 11, 2003
    Messages:
    611
    Likes Received:
    0
Loading...