1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

HOWTO fix: Qmail / DrWeb error after installing last qmail rpm

Discussion in 'Plesk for Linux - 8.x and Older' started by Griffith, Mar 31, 2006.

  1. Griffith

    Griffith Guest

    0
     
    If someone get the same problem as I have got on my servers, here you have a solution. (I guess this only occurs if you are running drweb)

    When I updated to the last release of plesk-7.5.4 I ran this (from base rpms):
    rpm -Uvh *750603* Mambo-4.5.2.3-7504.noarch.rpm

    These were installed then:
    72 -rw-r--r-- 1 psaadm psaadm 67538 Mar 22 21:19 psa-api-cli-7.5.4-rhel3.build75060321.20.noarch.rpm
    624 -rw-r--r-- 1 psaadm psaadm 633647 Mar 22 21:18 psa-api-common-7.5.4-rhel3.build75060321.20.noarch.rpm
    1232 -rw-r--r-- 1 psaadm psaadm 1256625 Mar 22 21:17 psa-hotfix6-7.5.4-rhel3.build75060321.20.i586.rpm
    2296 -rw-r--r-- 1 psaadm psaadm 2344686 Mar 22 21:17 psa-qmail-1.03-rhel3.build75060321.20.i586.rpm
    5620 -rw-r--r-- 1 psaadm psaadm 5742159 Mar 22 21:19 Mambo-4.5.2.3-7504.noarch.rpm

    The problem is qmail. When the last rpm of qmail is installed it destroys ownership AND installs wrong qmail-queue file (I guess this will only happen if you use drwebd)

    The result is (/var/qmail/bin)

    16 -r-s--x--x 1 qmailq qmail 14808 Mar 21 15:57 qmail-queue
    164 -r-xr-xr-x 1 root qmail 161024 Aug 25 2005 qmail-queue.drweb
    16 -r-xr-xr-x 1 root qmail 14808 Aug 24 2005 qmail-queue.origin


    to fix this I ran:
    chmod 4511 /var/qmail/bin/qmail-queue*
    chown drweb:qmail /var/qmail/bin/qmail-queue*
    chown qmailq:qmail /var/qmail/bin/qmail-queue.origin
    cp /var/qmail/bin/qmail-queue.drweb /var/qmail/bin/qmail-queue -p

    which gives this:
    164 -r-s--x--x 1 drweb qmail 161024 Aug 25 2005 qmail-queue
    164 -r-s--x--x 1 drweb qmail 161024 Aug 25 2005 qmail-queue.drweb
    16 -r-s--x--x 1 qmailq qmail 14808 Aug 24 2005 qmail-queue.origin


    In the maillog I got these errors:
    qmail-queue: dwlib: runner: submitter[31590] with error code 62
    qmail-queue: dwlib: mail: wait for submitter failed
    qmail-queue: drweb-qmail[30049]: cannot reinject message to mail system
     
  2. albans

    albans Regular Pleskian

    26
     
    Joined:
    Nov 29, 2005
    Messages:
    173
    Likes Received:
    0
    I asked SWSoft support for this error and they fixed the problem...

    Here's their answer:
    -------------------------------
    I've reinstalled drweb packages to fix permissions and owners of qmail-queue* files, now they are correct.

    Also I changed value of "LicenseLimit" from "reject" to "pass" in config /etc/drweb/drweb_qmail.conf, this allows drweb to avoid rejecting messages due to license limitation (a known problem that will be fixed in next patch 8.0.1).
    -------------------------------
     
Loading...