1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

HTTP won't start

Discussion in 'Plesk for Linux - 8.x and Older' started by timtrott, Jan 17, 2005.

  1. timtrott

    timtrott Guest

    0
     
    I set up a test box with RHEL ES3 and PSA Reloaded 7.5 to avoid making mistakes on my production server, but I can't get HTTP to start. I get the following error:
    =====
    Unable to make action: Unable to manage service by websrvmng: websrvmng: Service httpd failed to restart: Operation not permitted
    --------------------------------------------------------------------------------
    0: /usr/local/psa/admin/htdocs/server/restart_services.php:2 psaerror(string "Unable to make action: Unable to manage service by websrvmng: websrvmng: Service httpd failed to restart: Operation not permitted")
    ====
    What did I do to cause this problem?
     
  2. hardweb

    hardweb Guest

    0
     
    Can you start it from command line with:

    /etc/init.d/httpd restart

    ?
     
  3. timtrott

    timtrott Guest

    0
     
    Stopping HTTP [FAILED]
    Starting HTTP [FAILED]
     
  4. NightStorm

    NightStorm Guest

    0
     
    tail -n 50 /etc/httpd/logs/error_log

    What's the output? It should give an idea of why httpd is failing to start...
     
  5. Snapdragon

    Snapdragon Guest

    0
     
    I got the same "operation not permitted" error last week.

    It was because the httpd.conf file got messed up and there was a <directory> statement nested incorrectly.

    Go to your /etc/httpd/conf/httpd.conf and make sure that the "Include /etc/httpd/conf/httpd.include" statement is LAST in the file and not part of a directory statement.

    The error was happening because the httpd.include file was trying to set the NameServer addresses and was failing due to being in a nested directory statement.

    See if that helps?
     
  6. Brian

    Brian Guest

    0
     
    See next Thread

    I have the same problem..
     
  7. Brian

    Brian Guest

    0
     
    Error_log Reads

    [warn] RSA server certificate CommonName (CN) 'plesk' does NOT match server name!

    [warn] RSA server certificate ia a CA certificate. (Basic) constraints: CA == TRUE!

    [alert] (22002) Name or service not known: mod_unique_id: unable to find IPv4 address of server002.domain.net. Configeration failed
     
  8. timtrott

    timtrott Guest

    0
     
    Thanks for the log suggestion. I knew it was being logged somewhere, I just didn't know where.

    My problem has to be something simple and stupid.

    The error log says "Name or service not known... Unable to find IPv4 address if cyber2.cyberchute.com"

    Somewhere I named this box cyber2.cyberchute.com but I didn't tell it that it lives at 192.168.0.110 (local network). Now I have to figure out where that is or figure out how to turn it back into "localhost".
     
  9. Brian

    Brian Guest

    0
     
    The httpd.conf log

    Both logs on the servers are fine. "timtrott" any ideas
     
  10. timtrott

    timtrott Guest

    0
     
    Not really. Maybe Nightstorm or Hardweb will suggest an answer that will solve the problem for both of us.
     
  11. Brian

    Brian Guest

    0
     
    what about the "/etc/hosts" file, thats the first thing that comes to mind
     
  12. timtrott

    timtrott Guest

    0
     
    It says:

    127.0.0.1 cyber2 localhost.localdomain localhost

    What should it be? I changed it and that killed PSA so I put it back as above.

    How can I uninstall PSA to reinstall it without having to spend half the night reloading the whole box with RHEL?
     
  13. Brian

    Brian Guest

    0
     
    I found this in Google

    Disable mod_unique_id in httpd.conf to get it back up-and-running. The real error is probably in /etc/resolv.conf not pointing to a valid nameserver.

    No - there's a relation between mod_unique_id and DNS (and a relation between mod_unique_id and mod_user_track and a relation between HostNameLookups and DNS).

    By: Melvyn Sopacua
     
  14. timtrott

    timtrott Guest

    0
     
    BINGO! That did it! Thanks!

    I put a # in front of the line with mod_unique in host.conf and did service httpd restart. [OK]

    You just saved me an "all-nighter".

    Since it's local it needs to point at itself for a nameserver.

    I hope I keep track of everything that gets changed in case I need to use this box as a backup for the production server in a hurry.

    Actually it's not really fixed yet.

    I can start http, I can see the default html file but it won't connect FTP.

    I need it to think it is its own nameserver. I did it once before by accident somehow.

    Come to think of it, I think it was running fine before I ran the last pile of up2dates. That might be a warning....
     
  15. Brian

    Brian Guest

    0
     
    Happy for you

    But what was it and what did you do to fix it?
     
  16. Brian

    Brian Guest

    0
     
    Try editing your /etc/httpd/conf/httpd.conf, go to ServerName directive and specify some value over there - even localhost will do..

    This would get rid of the warning message.
     
  17. timtrott

    timtrott Guest

    0
     
    Checking services --status-all I am finding ypbind and mailman are not running. FTP not accessing.

    Starting mailman -- complains that sitelist is missing.

    Life goes on....

    Spending the night reloading RedHat and starting over is starting to look good again....

    Was that 'older server' question directed to me? I have a production server running, this is my previous box reloaded with Reloaded.
     
  18. Brian

    Brian Guest

    0
     
    Still here....

    I'm still working on it.
     
  19. Brian

    Brian Guest

    0
     
    Does this work?

    I'm not totally sure this is right for the plesk software but it works.

    Edit your /etc/hosts file and verify that there's a line in there that reads:

    127.0.0.1 localhost localhost.localdomain
    192.168.0.110 cyber2 cyber2.cyberchute.com

    This gives the httpd the answer it needs to work. And yes it does work, both of my server are up and running now.
     
  20. Brian

    Brian Guest

    0
     
    Running out of ideas

    This solves httpd problem but starts other problems... like Mailman goes down.

    Anyone have any ideas?
     
Loading...