1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

httpdocs lost permissions

Discussion in 'Plesk for Linux - 8.x and Older' started by unsichtbarre, Oct 27, 2007.

  1. unsichtbarre

    unsichtbarre Guest

    0
     
    the httpdocs folder in most of my domains (30 out of 40) lost its permissions last night. That is to say, they went from 777 or 755 to ---, notheing at all, at the command line it looked like this:

    what could cause this to happen. I temporarily fixed it with:
    but that only gets my pages back online, anyone know why this happened or how I can fix it?

    -John
     
  2. raaqi

    raaqi Guest

    0
     
    That's very concerning, anyone have an explaination?
     
  3. jaredfine

    jaredfine Guest

    0
     
    Was the file mod time the same for all the files? Did you look in the logs or bash history to see if you could figure out who might have changed them? Is anything else changed on the box? That is very odd to say the least.
     
  4. unsichtbarre

    unsichtbarre Guest

    0
     
    All happened at about the same time. No significant entries in the logs to lead me to any conclusions. Hasn't happened since.
     
  5. jaredfine

    jaredfine Guest

    0
     
    Never heard of that happening. Hope it was a one time fluke sort of thing.
     
  6. dirty@

    dirty@ Guest

    0
     
    maybe you set expiration time for domain in plesk and it expired, so that disabled automatically and permissions are set such way? or client account was disabled...

    try to check this, i'm too lazy at the moment to check it on my plesks :) i just remember that similar happens with mail accounts - if you remove option 'mailbox' for mail account, then permissions of mail folder qmail/mailnames/domain.tld/mailuser are switched to 000
     
Loading...