• Halloween is coming! To celebrate the occasion, we dusted off a couple of old skins, and even created a brand new one (Pixel).
    To get into the festive spirit, install the Skins extension.
  • The new Python extension is now available. It allows customers to deploy and manage WSGI-based Python applications on their websites directly from Plesk.
  • The Plesk Mobile apps for iOS and Android and the Plesk Mobile Center extension have been deprecated, and are no longer available for new installations. In Plesk Obsidian 18.0.84, the Plesk Mobile Center extension will be removed from servers during the upgrade, and the Plesk Mobile apps will lose their server management features.
  • The Social Login extension has been deprecated and will be removed in Plesk Obsidian 18.0.84. After that, it will no longer be possible to log in to Plesk with a Google, Facebook, GitHub account, or with a passkey. Plesk usernames and passwords, as well as logging in with a WebPros Account, are not affected.

I need to upgrade apache 2.0.54 to a newer version

M

micmac@

Guest
Hello,

How can I upgrade the version of apache2
that comes with plesk to a newer version ?

Plesk comes with apache 2.0.54, but there
is an important security fix in apache
2.0.59

How can I upgrade the current version
of apache in plesk 8.1 linux to this
newer 2.0.59 version ? (I'm not even
asking to upgrade to the new 2.2 apache...)
 
just look to an update of your linux distribution, plesk use the version of your installed linux ...
 
ok, thanks for the answer.

I had a manual installation of apache 2.2
(I mean building it from the source) on
Debian Sarge before installing Plesk.


I guess that's why plesk didn't find
it, since I din't install it with apt.

Too bad that the 2.2 version of apache2
is not released in debian paquets for
Sarge then.

I have to wait for the upcoming Plesk
8.2 to move to Etch and solve those
problems, as everybody else I guess.
 
If you're using a distribution that is still supported by the vendor (and if you're running Debian Sarge, you are) there is no need to install the latest version to get the security patches. A lot of distributions do backports instead of version upgrades. You might want to read this (Red Hat) document that explains the backporting process: http://www.redhat.com/advice/speaks_backport.html

In short: if you're running the latest apache that apt-get has for you, there is nothing to worry about. If you really need new features that are not available in the latest version that your distro is supplying, *then* it's time for more complex operations.
 
Ok! The security issues are fixed,
even if the version number is slightly
the same.

I'll keep my current apt updated version
then, thanks for explaining the
backporting principle to me :)
 
Back
Top