1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

I need to upgrade apache 2.0.54 to a newer version

Discussion in 'Plesk for Linux - 8.x and Older' started by micmac@, Jul 4, 2007.

  1. micmac@

    micmac@ Guest

    0
     
    Hello,

    How can I upgrade the version of apache2
    that comes with plesk to a newer version ?

    Plesk comes with apache 2.0.54, but there
    is an important security fix in apache
    2.0.59

    How can I upgrade the current version
    of apache in plesk 8.1 linux to this
    newer 2.0.59 version ? (I'm not even
    asking to upgrade to the new 2.2 apache...)
     
  2. danliker

    danliker Silver Pleskian Plesk Certified Professional

    33
    43%
    Joined:
    Feb 15, 2006
    Messages:
    575
    Likes Received:
    0
    Location:
    Switzerland
    just look to an update of your linux distribution, plesk use the version of your installed linux ...
     
  3. micmac@

    micmac@ Guest

    0
     
    ok, thanks for the answer.

    I had a manual installation of apache 2.2
    (I mean building it from the source) on
    Debian Sarge before installing Plesk.


    I guess that's why plesk didn't find
    it, since I din't install it with apt.

    Too bad that the 2.2 version of apache2
    is not released in debian paquets for
    Sarge then.

    I have to wait for the upcoming Plesk
    8.2 to move to Etch and solve those
    problems, as everybody else I guess.
     
  4. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    If you're using a distribution that is still supported by the vendor (and if you're running Debian Sarge, you are) there is no need to install the latest version to get the security patches. A lot of distributions do backports instead of version upgrades. You might want to read this (Red Hat) document that explains the backporting process: http://www.redhat.com/advice/speaks_backport.html

    In short: if you're running the latest apache that apt-get has for you, there is nothing to worry about. If you really need new features that are not available in the latest version that your distro is supplying, *then* it's time for more complex operations.
     
  5. micmac@

    micmac@ Guest

    0
     
    Ok! The security issues are fixed,
    even if the version number is slightly
    the same.

    I'll keep my current apt updated version
    then, thanks for explaining the
    backporting principle to me :)
     
Loading...