1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

index.php in root directories not parsing after PHP5 upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by yowzer, May 13, 2006.

  1. yowzer

    yowzer Guest

    0
     
    I tried searching, but I didn't quite find this specific problem described anywhere. I used one of the PHP5 walk-throughs for upgrading PHP to version 5 in Plesk 7.5.x. It works perfectly except for one thing.

    Instead of index.php in the root directory, it is being sent as plain text with content-type application/x-httpd-php. It's a very strange thing because PHP is working fine in most places.

    In a sample directory tree, all of these work fine:
    /blort.php
    /pics/
    /pics/index.php

    The strangest thing is that while http://www.mydomain.com/ returns the PHP file as text, http://mydomain.com/ compiles the PHP and sends the HTML properly.

    I am on Plesk 7.5.3 and PHP 5.1.4.
     
  2. yowzer

    yowzer Guest

    0
     
    This is the guide I used:
    http://forums.serverbeach.com/showthread.php?t=6125

    Even more strange in this whole situation is that when I was going to start some more troubleshooting, everything was working fine. While I hate not knowing what the issue was (I suspect Apache was caching), it's at least resolved now.

    I still need to upgrade some PEAR packages for Horde to work, but it looks like things went fine.
     
Loading...