1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Install script fails on CentOS

Discussion in 'Plesk for Linux - 8.x and Older' started by awesomejt, Aug 10, 2006.

  1. awesomejt

    awesomejt Guest

    0
     
    I am completely unable to install Plesk 8.01 on CentOS -- I've tried 4.3 and 4.2 without success. Regardless of the version, the installer complains about perl-HTML.noarch possible version mismatch and then dies. Anyone else seeing this problem?

    Both cases are a fresh install of CentOS. I've tried a clean install before yum updating and after. I've tried ServerCD install and normal install -- no joy either way.
     
  2. Highland

    Highland Guest

    0
     
    Try uninstalling the offending package and see if that fixes it.
     
  3. Who-m3

    Who-m3 Guest

    0
     
    If you provide us with a bit more information as to what exactly it's telling you, we may be able to provide you with more reasons as to what exactly is going on...
     
  4. frostie

    frostie Guest

    0
     
    I installed on Centos 4.2 cds. Basic including server tools and dns. Then I did a "yum -y update". Restarted the server and it came up as 4.3 Final verison. Then I ran the auto-install script and it did a perfect job. No errors at all. It installed all the needed packages for me.
     
  5. awesomejt

    awesomejt Guest

    0
     
    My home internet access is down right now (I'm posting from work). However, I'll create a camtasia video of my experience to show what is going on. I'll post the URL this weekend. BTW, I'm using VMWare to test the install of CentOS and Plesk before attempting on a production box.
     
  6. Garp

    Garp Guest

    0
     
    I always do a 'custom' (text-based) setup of CentOS 4 and then deselect ALL packages. You only need cd 1 then. I truly dislike unneeded rubbish :)

    After installation, reboot, login, import the pgp key, do a;

    # yum -y install yum-plugin-fastestmirror && yum -y update && reboot

    Then install plesk through the script. Works for me. Don't forget to install bastille and tripwire though.
     
  7. awesomejt

    awesomejt Guest

    0
     
    Some interesting results

    Ok, I've had some success over the weekend with CentOS and Plesk.

    First of all, I was mostly using the "Server CD" install which is only one CD that is supposed to setup the most common server configuration. On both CentOS 4.2 and 4.3 -- Plesk did not like that arrangement at all.

    I did what I considered "basic" installs using the "Server" option during the install and didn't choose anything except the standard stuff. On both 4.2 and 4.3 the auto installer gave me trouble.

    I did another install (4.3), chose the Server option as part of the install but also chose to install "mysql-server", the Web Server, DNS Server, Database Server, and Development groups to install besides the default. I also, drilled into the Development group and choose everything related to PERL -- including the xml packages. I'm not sure if all that was required, but the Plesk auto installer had no problems with that setup and sailed right through. I'll try other setups -- including "minimum" and "everything" to see what works (or not).
     
  8. drtaber

    drtaber Guest

    0
     
    I'm running into the same problem. It has to be distro related in some way, but i've yet to figure out what the problem is caused by yet.

    A month ago i did an install and it worked fine. I can do a Plesk 8.0 installation and it will work fine, however everytime i've tried installing plesk over the past week it has given the same error.

    The error is:

    package perl-html-tree-1:1:3.16-centos4.2.build8000613.20.noarch listed in inf3, but not found in build headers, possible version mismatch


    EDIT: Found the solution here:
    http://forum.swsoft.com/showthread.php?threadid=35157


    Turns out the installer was out of date. New version since i last used it.
     
Loading...