1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Installing PEAR with Plesk 8

Discussion in 'Plesk for Linux - 8.x and Older' started by teknoledge, Aug 28, 2006.

  1. teknoledge

    teknoledge Guest

    0
     
    I have a problem with configuring PEAR on my server.

    Server is running on CentOS with PHP 4.3.9

    Here is the PEAR configuration:
    Configuration (channel pear.php.net):
    =====================================
    Auto-discover new Channels auto_discover <not set>
    Default Channel default_channel pear.php.net
    HTTP Proxy Server Address http_proxy <not set>
    PEAR server [DEPRECATED] master_server pear.php.net
    Default Channel Mirror preferred_mirror pear.php.net
    Remote Configuration File remote_config <not set>
    PEAR executables directory bin_dir /usr/bin
    PEAR documentation directory doc_dir /usr/share/pear/docs
    PHP extension directory ext_dir /usr/lib/php4
    PEAR directory php_dir /usr/share/pear
    PEAR Installer cache directory cache_dir /tmp/pear/cache
    PEAR data directory data_dir /usr/share/pear/data
    PEAR Installer download download_dir /usr/temp/download
    directory
    PHP CLI/CGI binary php_bin /usr/bin/php
    PEAR Installer temp directory temp_dir /usr/temp
    PEAR test directory test_dir /usr/share/pear/tests
    Cache TimeToLive cache_ttl 3600
    Preferred Package State preferred_state stable
    Unix file mask umask 22
    Debug Log Level verbose 1
    PEAR password (for password <not set>
    maintainers)
    Signature Handling Program sig_bin /usr/bin/gpg
    Signature Key Directory sig_keydir /etc/pearkeys
    Signature Key Id sig_keyid <not set>
    Package Signature Type sig_type gpg
    PEAR username (for username <not set>
    maintainers)
    User Configuration File Filename /root/.pearrc
    System Configuration File Filename /etc/pear.conf

    I also added into the vhost.conf this:

    <Directory /var/www/vhosts/serverinn.com/httpdocs>
    php_admin_value open_basedir /var/www/vhosts/serverinn.com/httpdocs:/tmp:/usr/share/pear
    </Directory>

    I want to enable PEAR on all domains automatically but whatever I do it doesnt work. Does anyone have similar problem?

    Thanks,
    Milos
     
Loading...