1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Invalid command 'IndexIgnore'

Discussion in 'Plesk for Linux - 8.x and Older' started by tsnoke, Apr 28, 2005.

  1. tsnoke

    tsnoke Guest

    0
     
    I just tried to bring up a new domain on a RHES3v3 Plesk Reloaded 7.5.2 server and ran into a concerning bit...

    This site has front page extensions enabled and the .htaccess page in /home/httpd/vhosts/domain.net/httpdocs/.htaccess shows:
    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName domain.net
    AuthUserFile /home/httpd/vhosts/domain.net/httpdocs/_vti_pvt/service.pwd
    AuthGroupFile /home/httpd/vhosts/domain.net/httpdocs/_vti_pvt/service.grp


    but all attempts at access a page result in a server error page.

    The error log shows:
    [Thu Apr 28 07:44:26 2005] [alert] [client 68.232.111.236] /home/httpd/vhosts/domain.net/httpdocs/.htaccess: Invalid command 'IndexIgnore', perhaps mis-spelled or defined by a module not included in the server configuration

    But if I comment out the IndexIgnore, it works.

    Any thoughts on the root issue here?

    Thanks in advance,

    -Timur
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    The contents are correct. Check all your Group ownership on the files.

    Group 'psaserv' should be owner for files
     
  3. tsnoke

    tsnoke Guest

    0
     
    the permissions look to be correct:

    # ls -l .htaccess
    -rw-r--r-- 1 rradmin psaserv 393 Apr 28 07:56 .htaccess

    but if i turn on FP support it recreates this file and turns:

    #IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    back into:
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    and brings the site down again.

    Thoughts?
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    I would try re-installing the frontpage RPM. Was your server 'upgraded' to 7.5.2 from an earlier version?

    Many of the problems I have had with other Plesk servers were resolved by using ART's yum repository files. ART is definitely a life saver!
     
  5. tsnoke

    tsnoke Guest

    0
     
    i am running a vanilla server that had Plesk 7.5.2 loaded on it...

    it looks like it is running the same version of frontpage as ART:
    # rpm -q frontpage
    frontpage-5.0-70psa.rhel3

    I will download it and reinstall it during a maintanence window.

    Any other ideas?
     
  6. jamesyeeoc

    jamesyeeoc Guest

    0
     
Loading...