1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

IP Hosting Domain (non_ssl mapping problem)

Discussion in 'Plesk for Windows - 8.x and Older' started by Grafix, Mar 17, 2004.

  1. Grafix

    Grafix Guest

    0
     
    I've got Windows Server 2003 setup with Plesk 6.5.2 working correctly. We do hosting such that each domain gets it's own IP address. The problem is that each domain/IP that we setup gets the root web site mapped to the same folder... in my case d:\Server Root\vhosts\default\htdocs, every single IP/domain added through Plesk defaults to that directory, then each domain has a virtual directory that corresponds to 'domain.com_non_ssl'..

    The problem is that if you go to www.domain.com, you'll get automatically mapped to www.domain.com/domain.com_non_ssl. But, if you go to the IP address http://xxx.xxx.xxx.xxx, you'll always get to the default plesk page... to get to the actual web site you need to go to http://xxx.xxx.xxx.xxx/domain.com_non_ssl... that's very frustrating... what's the point in having an IP per domain if you can't even use the IP to address the web site... any workarounds? Anyway to get the default page for each account to actually point to the account it's supposed to??????

    Consider setting up new hosting for a domain whose DNS needs to be updated. Typically you'd need to give the IP address to your customer in order to allow them to access the site while DNS is being updated.. but with Plesk, you'd have to tell them to goto http://xxx.xxx.xxx.xxx/domain.com_non_ssl... frustrating, frustrating, etc...
     
  2. lancer28a

    lancer28a Guest

    0
     
    RE: IP Hosting Domains (Non_ssl)

    What I had to do to resolve this issue is once the domain is created, go into IIS and point it to the correct directory.

    If you have any experience in Windows Hosting, this is a common step. I am sure there is a good reason why this happens and what not and there will probably be a hotfix to address the issue but untill then, we are stuck doing things the old way.

    Also make sure that all of ur mappings are set for each domain.

    Perl
    ASP
    ASP.Net
    etc, etc.
     
  3. siren@

    siren@ Guest

    0
     
    This is not the proper way to do this.

    What is going on is you have not gone to either the client IP Pool nor IP aliasing on the server and set the domain to be the default on the domain.

    By setting the default domain for the ip this will correct the IP issue.
     
  4. emsol

    emsol Guest

    0
     
    I need to set the default domain but this is set to "none" and greyed out.

    How can the default domain be set ?
     
  5. Gremlin

    Gremlin Guest

    0
     
    In the Server System menu, select IP Aliasing.

    Click the number under the column with the heading "H" for the IP you want to set a default for.

    You can then select which hosted domain should be the default from the screen that follows.
     
  6. emsol

    emsol Guest

    0
     
    DOH !

    Thank you. :eek:
     
  7. Gremlin

    Gremlin Guest

    0
     
    It's not really all that intuitive is it ... very easy to miss that one.
     
Loading...