1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

JavaMail failing in Plesk PowerPack

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by danipage, Feb 12, 2011.

  1. danipage

    danipage Guest

    0
     
    Hi everyone,

    I've recently rented a dedicated server with Plesk control panel and the PowerPack license

    This is my configuration:

    - CentOS release 5.5 (Final)
    - Kernel 2.6.34.6-xxxx-std-ipv6-64
    - Apache/2.2.3
    - OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008
    - Plesk 9.5.4
    - PowerPack with the following:
    - tomcat5-5.5.23-0jpp.9.el5_5
    - java version "1.4.2"
    - jre 1.4.2
    - gij (GNU libgcj) version 4.1.2 20080704 (Red Hat 4.1.2-48)


    This is the JSP I'm trying to execute (a working example from the Internet):


    This is the error obtained when reaching the "Transport.send(message);" instruction:


    Also, I've granted "permission java.security.AllPermission;" in catalina.policy for the related domain



    I think that Plesk and PowerPack have an issue here, because this is a fresh installation, I haven't performed any manual update, and JavaMail is not working



    On the flip side, I can only think about manually updating JRE, but at first I don't like the idea, as I would prefer updating Plesk only via admin panel for better standardization the deployment of virtual sites

    Any clue for solving this issue?
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    I assume that your JSP connects to SMTP server, invokes STARTTLS command, receives certificate of SMTP server and then sends encrypted data back. Most probably server replies with this error like:
    Check it in logs.
    It appears that application sends incorrect SSL data.
    Most possible cause is that JSP cannot properly initiate SSL session.

    At least try to disable
     
  3. danipage

    danipage Guest

    0
     
    Hi, thanks!

    But I already tried that against the local SMTP

    No TLS, No SSL, etc. and still obtaining same error:

    That's why I think that Java, or Tomcat, or OpenSSL are not properly aligned

    Also, please note that my server is 64 bits, maybe is it lacking some Java lib?
     
  4. danipage

    danipage Guest

    0
     
    Hi,

    I managed to solve it

    It's a matter of fact that Java 1.4.2-gcj and Java 1.6.0-openjdk (both available @ yum list) are not working well with CentOS

    So I had to rebuild Java 1.6.0-sun from source code

    If your OS is CentOS, and you need Java, then follow this guide: http://wiki.centos.org/HowTos/JavaOnCentOS
     
Loading...