1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Kernel 3.0.x und PSA-Firewall

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by UeckerO, Sep 17, 2011.

  1. UeckerO

    UeckerO Guest

    0
     
    Hallo,

    ich hoffe hier ist jemand der deutschen Sprache mächtig, denn seit einem Kernel-wechsel unseres Servers, will die PSA-Firewall nicht mehr starten, und bringt folgende Meldung im Plesk Panel-Version 10.3.1:

    Unsupported kernel version: 3.0.4

    0: common_func.php3:139
    psaerror(string 'Unsupported kernel version: 3.0.4')
    1: BackendLinux.php:22
    BackendLinux->BackendLinux(array)
    2: FwConfigurator.php:311
    FwConfigurator->render(integer '2')
    3: modules.firewall.edit.activate.php:44
    plesk__modules__firewall__edit__activate->accessItem(string 'GET', NULL null)
    4: UIPointer.php:595
    UIPointer->access(string 'GET')
    5: plesk.php:52

    Wenn ich das Firwall Script manuell ausführe, wird Iptables gestartet und meine Ports die ich absichern will sind geschlossen.

    Gibt es eine Möglichkeit trotz dessen, die Firewall im Plesk zu starten?

    MfG

    Uecker
     
    Last edited by a moderator: Sep 17, 2011
  2. UeckerO

    UeckerO Guest

    0
     
    PushPushPush
     
  3. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,534
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    Sorry, but English is official language on this forum.
     
  4. UeckerO

    UeckerO Guest

    0
     
    Hello,

    because for a kernel change our server will not start the PSA firewall, and brings the following message in the Plesk panel version 10.3.1:

    Unsupported kernel version: 3.0.4

    0: common_func.php3:139
    psaerror(string 'Unsupported kernel version: 3.0.4')
    1: BackendLinux.php:22
    BackendLinux->BackendLinux(array)
    2: FwConfigurator.php:311
    FwConfigurator->render(integer '2')
    3: modules.firewall.edit.activate.php:44
    plesk__modules__firewall__edit__activate->accessItem(string 'GET', NULL null)
    4: UIPointer.php:595
    UIPointer->access(string 'GET')
    5: plesk.php:52

    If I manually run the script Firwall, iptables is started and I want to protect my ports are closed.

    Is there a way in spite of it, the start firewall in Plesk?

    MfG

    Uecker


    PS. If you offer products in Germany, one should also offer a German support. Each and everyone assumes that you have mastered English, which is unfortunately not always so.
     
    Last edited by a moderator: Sep 20, 2011
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,534
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    As I see you have latest version of Linux kernel - 3.0.4
    Officially Plesk support only kernels from supported OS vendor repositories.
     
  6. UeckerO

    UeckerO Guest

    0
     
    Hello!

    The 3.0.x kernel has long been realsed and officially to refer to Kernel.org. How long can it take until I can control the firewall again with Plesk PSA? I've only once built himself a iptables script so that my server is back safe.


    MfG

    Uecker
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,534
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
    I don't know what is OS you have but when kernel 3.0.4 version will be officially supported by OS vendor and included to official OS vendor's repository - it will be supported by Plesk too.
     
  8. UeckerO

    UeckerO Guest

    0
     
    I use Debian 6.0 but to the extent it ever since I can use the script from the firewall by PSA. Or sometime then some games to go running at least Froxlor mixed platform independent and not so great in the system and what you do what you expect from a program to control the server and does not care about the kernel you want to use.
     
  9. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,534
    Likes Received:
    1,239
    Location:
    Novosibirsk, Russia
    Affiliate:
    https://plesk.com/?a_aid=59ae552b0731c
Loading...