1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mail: DNSBL before AUTH after update to 10.1

Discussion in 'Plesk 10.x for Linux Issues, Fixes, How-To' started by MarcoJ, Mar 1, 2011.

  1. MarcoJ

    MarcoJ New Pleskian

    16
    60%
    Joined:
    Nov 7, 2010
    Messages:
    16
    Likes Received:
    0
    Hi,

    i've upgraded from Plesk 10.0.1 to 10.1 and i've noticed problems in using my server as a smarthost for my local mailserver. Checking the SMTP communication, i've seen that Plesk now processes the DNSBL list first, discarding the connection request from my IP.

    Normally (and the behaviour before 10.1) there should be the chance to do SMTP auth before cancelling a connection due to DNSBL matches.

    Has anybody a hotfix for this (I'm using the standard qmail for SMTP)? Also a parallels employee may read this and put this issue in the bugtracker for the next fix release.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
  3. MarcoJ

    MarcoJ New Pleskian

    16
    60%
    Joined:
    Nov 7, 2010
    Messages:
    16
    Likes Received:
    0
    Dear Igor,

    here it is ;-)

    However, if there is any hotfix solution for this issue please feel free to post the solution.

    ---------------------------------------------------------------
    PRODUCT, VERSION, OPERATING SYSTEM, ARCHITECTURE
    Plesk for Linux, 10.1.1, Debian Lenny, Linux 2.6.18-5-amd64

    PROBLEM DESCRIPTION AND STEPS TO REPRODUCE
    After Update from Plesk 10.0.1 to 10.1.1, the DNSBL is checked prior to the checking for SNTP AUTH on port 25. This breaks the connection for IP's listed on DNSBL (like dynamic IP's) even before they have a chance to authenticate.
    Plesk is set to use qmail (default setting).
    Also putting the IP on the whitelist should skip DNSBL, but Whitelisting has no effect to the DNSBL checking.

    ACTUAL RESULT
    Immediately after connecting to port 25 for a SMTP session, the connection is ended by DNSBL checking if the connecting IP is listed in DNSBL. There is no chance to authenticate before.
    Putting the IP on the Whitelist will not skip the DNSBL check, the connection is also ended by DNSBL check if the IP is on the whitelist.

    EXPECTED RESULT
    The SMTP AUTH should be processed first, giving mailbox owners the chance to use SMTP with authentication also on port 25. Only for unauthenticated sessions, the DNSBL check should be performed.
    If the IP is entered on the whitelist, DNSBL should be skipped and the IP should be allowed to do the session.

    ANY ADDITIONAL INFORMATION
    --------------------------------------------------------------
     
    Last edited: Mar 2, 2011
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Thank you. I have forwarded it to developers. I will update thread with any useful information as soon as I receive it.
     
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Use the attached binary for deb50x64. Enable/disable DNSBL to force it to recreate config.
     

    Attached Files:

  6. zacahryw

    zacahryw Guest

    0
     
    having this same problem, all my clients on dynamic address, even though they auth on smtp DNSBL still drops them.
     
  7. DragonAss

    DragonAss New Pleskian

    22
    23%
    Joined:
    Apr 15, 2008
    Messages:
    5
    Likes Received:
    0
    Add one more to the pot - suspect same issue

    Some clients are experiencing this: when DNSBL is enabled, they can no longer use SMTP. Server drops the connection before the attempts are even logged.

    I tried the "mailmng.zip" quick fix for Debian but it caused some Exceptions on the mail server settings page. Unless I should start a new thead for it, I guess I'm requesting a version of this fix in RHEL5 flavor.
     
  8. jhuedder

    jhuedder New Pleskian

    22
    73%
    Joined:
    Sep 23, 2004
    Messages:
    24
    Likes Received:
    0
    May I ask for that bugfix for OSS 11.1 with Postfix?

    Thanx, Jörg Hüddersen
     
Loading...