1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

mail problem after running mchk

Discussion in 'Plesk for Linux - 8.x and Older' started by baravalle, Mar 15, 2008.

  1. baravalle

    baravalle Guest

    0
     
    Hi,
    after the upgrade from 8.1 to 8.3, some of my settings where resetted, and I was trying to stop mail bounces.

    One of the solutions that I have seen was to run mchk, which I did:

    /usr/local/psa/admin/sbin/mchk --without-spam

    as a result - my virtualdomains, rejectnonexists and rcpthosts files got wiped - with only the main domain remaing there.

    I have tried to rebuild the files using the mail table from the PSA database - but with partical success. At the present time, looks like the mail is delivered, but I cannot login any more with ANY user to read the mail.

    Example log line:

    Mar 15 15:22:09 baravalle imapd-ssl: IMAP connect from @ [##.##.##]checkmailpasswd: FAILED: #######@#######.## - no
    such user from @ [##.##.##]ERR: LOGIN FAILED, ip=[##.##.##]


    This is quite upsetting.

    Any suggestion?

    Andres
     
  2. baravalle

    baravalle Guest

    0
     
    With further checks, I have seen that the files users/assign and users/poppasswd have been wiped too. any suggestion on how to get them back?
     
  3. baravalle

    baravalle Guest

    0
     
    after some other work, I managed to get back users/assign - and a basic poppasswd.

    I can now access my old email - but none of my accounts can receive any new mail.

    In the meanwhile I have tried running again /usr/local/psa/admin/sbin/mchk (after making backup copies of the files) and I can confirm that it deletes my mail configuration files. I find it quite disturbing - it's been already 4 hours in front of the computer for just using a PLESK utility.

    Any suggestion on where to look why my accounts are not receiving any new mail?
     
  4. tiramisu_

    tiramisu_ Guest

    0
     
    mchk utility should b eused with caution. It actually reset all custom changes and reconfigure mail settings according to Plesk db.
     
  5. tiramisu_

    tiramisu_ Guest

    0
     
    ok, if you sent email is there anything in /usr/local/psa/var/log/maillog?

    did you receive any error in webmail? mail client?

    there is should be something to move from
     
  6. silebis

    silebis Guest

    0
     
    Partialy maybe same problem as i had.

    Check if you have in etc/courier-imap/* files these rows. In my was missing
    AUTHMODULES="authpsa" - in some authomodules exist, but without value.
    MAILPASSWD="/var/qmail/users/poppasswd"



    Just now i cant recieve any mail

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 554 554 5.7.1 <xyz>: Recipient address rejected: User unknown in valid users table (in reply to RCPT TO command) (state 14).
     
Loading...