1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Miva Empresa Installation

Discussion in 'Plesk for Linux - 8.x and Older' started by jcoulter, Feb 21, 2006.

  1. jcoulter

    jcoulter Guest

    0
     
    I'm still having trouble getting Miva Empresa to work but I'm getting closer. Based other forums posts and the miva user list ... here is what I am now getting when I try to run a .MVC script:

    "Configuration Error: mivaroot is not defined"

    I've taken the below steps in the installation. I am not installing this server wide, but to only one domain (for now).

    ------------------------------
    I have created the mivavm.conf file with the below contents.

    mivaroot=/var/www/vhosts/domain.com/httpdocs
    stdmodedatadir=/var/www/vhosts/domain.com/mivadata
    cadir=/var/www/vhosts/domain.com/cgi-bin/certs
    openssl=/usr/lib/libssl.so
    openssl_crypto=/usr/lib/libcrypto.so

    <BUILTIN-LIB LIBRARY = "/usr/local/miva/lib/builtins/crypto.so">
    <BUILTIN-LIB LIBRARY = "/usr/local/miva/lib/builtins/system.so">
    <BUILTIN-LIB LIBRARY = "/usr/local/miva/lib/builtins/file.so">
    <BUILTIN-LIB LIBRARY = "/usr/local/miva/lib/builtins/math.so">
    <BUILTIN-LIB LIBRARY = "/usr/local/miva/lib/builtins/string.so">
    <BUILTIN-LIB LIBRARY = "/usr/local/miva/lib/builtins/time.so">

    ------------------------------
    I have added the following to my /var/www/vhosts/domain.com/cgi-bin directory
    /certs user.psacln 755
    /lib user.psacln 755
    libmivaconf.so user.psacln 644
    mivavm user.psacln 755
    mivavm.conf user.psacln 644

    Note: I tried psaserv instead of psacln and received a "Internal Server Error" ... psacln at least allows mivavm to try to run

    ------------------------------
    I have added the following to my /var/www/vhosts/domain.com/conf/httpd.include file:

    AddType application/x-miva-compiled .mvc
    Action application/x-miva-compiled /cgi-bin/mivavm

    ------------------------------
    I have created the /var/www/vhosts/domain.com/mivadata directory with user.psaserv ownership and 750 permissions.

    ------------------------------
    I have stopped and restarted Apache

    ------------------------------
    Again, I am getting the following error: "mivaroot is not defined", which is defined in the mivavm.conf file. The system is apparently finding the Miva Engine just fine in order to generate the error message. Seems like the issue now is how to get it to recognize the mivavm.conf file.

    I'm running Plesk 7.5.4 on Fedora Core Release 2 (Tettnang). Trying to install Empresa v5.

    Now, after such a lenghtly post, I have one more word to add ...

    HELP!!!

    :)
     
  2. jremsey

    jremsey Guest

    0
     
    Has anyone found a solution to this? I am having the same issue but I am using PSA 7.5.4 on a CentOS 4.3 server.

    Does the apache psa uses allow environemtnal variables?

    I have tried setting teh variables in both the vhost.conf file and in an .htaccess file with out success.

    SetEnv MvCONFIG_LIBRARY /usr/local/miva/lib/config/env.so
    SetEnv MvCONFIG_DIR_MIVA /home/httpd/vhosts/domain.com/httpdocs/
    SetEnv MvCONFIG_DIR_DATA /home/httpd/vhosts/domain.com/mivadata
    SetEnv MvCONFIG_DIR_BUILTIN /usr/local/miva/lib/builtins

    Any suggestions would be great.

    Thanks.
     
Loading...