1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

MS SQL activation gives php error page

Discussion in 'Plesk for Windows - 8.x and Older' started by Tigr, Dec 18, 2004.

  1. Tigr

    Tigr Guest

    0
     
    After re installing plesk 7 for windows for the third time (which is what plesk support said to do) I still get the same error.

    When trying to input the sa username and password for the server settings I get :


    There is need to implement utility for creating/modification users.
    0: C:\Program Files\SWsoft\Plesk\admin\plib\database_mssql.inc:383 psaerror(string "There is need to implement utility for creating/modification users.")
    1: C:\Program Files\SWsoft\Plesk\admin\plib\class.DataBase.php3:498 database_mssql->changelogin(string "sa", boolean true, string "passwordt")
    2: C:\Program Files\SWsoft\Plesk\admin\plib\class.DatabasesAccess.php:150 database::changelogin(string "mssql", string "sa", boolean true, string "password")
    3: C:\Program Files\SWsoft\Plesk\admin\htdocs\server\databases.php:41 databasesaccess->update()


    Anyone able to help on this? Im more familiar with the unix plesk than windows.

    Thanks
    Matt
     
  2. cviviani

    cviviani Guest

    0
     
  3. Tigr

    Tigr Guest

    0
     
    Yeah have installed SP3 for SQL . But I think at this point the only choice will be reinstall.

    thanks for the guide
     
  4. henry@

    henry@ Guest

    0
     
    Tigr,

    Reinstall Plesk and Windows again will not give you any changes at all, I think there is a bug in the 7.03 updater. I have the same error when trying to activate MSSQL and I also reinstalled fresh Plesk and Windows 2003 STD maybe 5 times and still the same error.

    So please developers, please go ahead and confirm that this is a BUG or maybe ther eis a special setting needed for the updater to be installed on the server.

    Regards,
    Henry
     
  5. cviviani

    cviviani Guest

    0
     
    it seems to be an error of plesk . I tries to find out why.
    it looks thaht is the first sa password not set correct. i try shortle to set sa to none password - same failure.
    somthing is wrong in the mysql datapase "psa" for user sa.
     
  6. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    this is not the first thread about this, i think you should just give up and say 7.0.3 was a bad update for now until they plesk fixes it
     
  7. cviviani

    cviviani Guest

    0
     
    to fix the problem:

    with mysqlcc (from mysql.org) run sqlscript in misc:

    insert into misc (param,val) values
    ('mssql_admin_login','sa'),
    ('mssql_admin_passwd','password');

    password to your password

    when not exist also

    insert into misc (param,val) values
    ('MSSQLServer','localhost');
     
  8. henry@

    henry@ Guest

    0
     
    Could you explain it to me : Step-Be Step how to have it fixed please?

    Regards
     
  9. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    you just put the insert statements in a file

    then write mysqlcc filename I think (otherwise consult help for the command)
     
  10. cviviani

    cviviani Guest

    0
     
    download from www.mysql.org mysqlcc and install it.

    start mysqlcc and connect to localserver with your plesk username and password.
    select database psa then select table misc
    push icon sql - copy paste my script - press icon execute "!".
     
  11. aupimp

    aupimp Guest

    0
     
    I am also receiving this error while trying to connect PLESK 7 for WINDOWS to MS SQL...


    There is need to implement utility for creating/modification users.
    0: C:\Program Files\SWsoft\Plesk\admin\plib\database_mssql.inc:383 psaerror(string "There is need to implement utility for creating/modification users.")
    1: C:\Program Files\SWsoft\Plesk\admin\plib\class.DataBase.php3:498 database_mssql->changelogin(string "sa", boolean true, string "aetaXef5")
    2: C:\Program Files\SWsoft\Plesk\admin\plib\class.DatabasesAccess.php:150 database::changelogin(string "mssql", string "sa", boolean true, string "aetaXef5")
    3: C:\Program Files\SWsoft\Plesk\admin\htdocs\server\databases.php:41 databasesaccess->update()



    The instruction you gave were unclear to me since I have no experience with this stuff what so ever.

    is there any way to get some further help with this.


    thank you guys!
     
Loading...