1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

mysqld start failed

Discussion in 'Plesk for Linux - 8.x and Older' started by foscolino, Mar 16, 2005.

  1. foscolino

    foscolino Guest

    0
     
    /etc/init.d./mysqld start failed after install plesk 7.5.2

    this is log:

    050316 16:17:55 mysqld started
    050316 16:17:56 InnoDB: Out of memory in additional memory pool.
    InnoDB: InnoDB will start allocating memory from the OS.
    InnoDB: You may get better performance if you configure a bigger
    InnoDB: value in the MySQL my.cnf file for
    InnoDB: innodb_additional_mem_pool_size.

    can we help me?
     
  2. eWebtricity

    eWebtricity Guest

    0
     
    Have you tried doing what it suggested? Increase the memory pool size for innodb ?
     
  3. foscolino

    foscolino Guest

    0
     
    i have tried to increase the value of innoib;
    nothing!
     
  4. PSi_101

    PSi_101 Regular Pleskian

    27
    57%
    Joined:
    Oct 5, 2004
    Messages:
    166
    Likes Received:
    1
    The failing to start is not an INNODB problem.

    This problem may occur under OS FedoraCore 1, FC2, and CentOS. MySQL startup uses /usr/bin/mysqladmin utility with "ping" parameter, which requires administrator rights to be initialized. If there is Plesk installed in the system, the utility cannot be executed and it returns negative error code.

    To resolve it, you should modify MySQL startup script.
    In the /etc/init.d/mysqld script, find the following lines and insert -uadmin -p`cat /etc/psa/.psa.shadow` between /usr/bin/mysqladmin and "ping" as in the example below:

    # Spin for a maximum of ten seconds waiting for the server to come up
    if [ -n "`/usr/bin/mysqladmin ping 2> /dev/null`" ]; then
    break;
    else
    sleep 1;
    fi
    done
    if !([ -n "`/usr/bin/mysqladmin ping 2> /dev/null`" ]); then
    echo "Timeout error occurred trying to start MySQL Daemon."
    action $"Starting $prog: " /bin/false
    else

    # Spin for a maximum of ten seconds waiting for the server to come up
    if [ -n "`/usr/bin/mysqladmin -uadmin -p`cat /etc/psa/.psa.shadow` ping 2> /dev/null`" ]; then
    break;
    else
    sleep 1;
    fi
    done
    if !([ -n "`/usr/bin/mysqladmin -uadmin -p`cat /etc/psa/.psa.shadow` ping 2> /dev/null`" ]); then
     
  5. foscolino

    foscolino Guest

    0
     
    thanks a lot!!
    the problem is been resolved.

    Andrea M.
     
Loading...