1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Named error Need help ASAP ..

Discussion in 'Plesk for Linux - 8.x and Older' started by jdk007, Aug 10, 2006.

  1. jdk007

    jdk007 Guest

    0
     
    I upgraded to RHEL 4 Update 4 and now my named doesn't work... I get:

    etc]# /sbin/service named restart
    Stopping named: [FAILED]
    Starting named:
    Error in named configuration:
    none:0: open: /etc/named.conf: file not found
    [FAILED]

    Any idea how to fix this?


    also named.conf is link:

    etc]# ls -la named.conf
    lrwxrwxrwx 1 root root 32 Aug 10 18:52 named.conf -> /var/named/chroot/etc/named.conf
     
  2. Who-m3

    Who-m3 Guest

    0
     
    ls -al /var/named/chroot/etc/named.conf, see if that file exists, because it's appearing that the file is missing at this point.
     
  3. jdk007

    jdk007 Guest

    0
     
    It does exist. Seems like domain information from plesk is found in /var/named/run-root/etc/named.conf really weird why two conf are there ....
     
  4. kturby

    kturby Guest

    0
     
    I'm seeing exactly the same thing after the RHEL upgrade. Is there a solution? Help!
     
  5. jwdick

    jwdick Guest

    0
     
    Verify that your named.conf is actually in /var/naned/run-root/etc/

    Then change your symlink in /etc to point to /var/named/run-root/etc/named.conf

    Restart named and you should be ready to go.
     
  6. kturby

    kturby Guest

    0
     
    I see where you're going, but changing the symbolic link didn't quite work.

    It's weird. I checked a backup of etc. Prior to this RHEL update, the /etc/named.conf was a symbolic link to:

    /var/named/run-root/etc/named.conf

    After the RHEL update, /etc/named.conf is a symbolic link to:

    /var/named/chroot/etc/named.conf

    If I look at /var/named/run-root/etc/named.conf -- IT IS (at least now) a SYMBOLIC link also -- to:

    /var/named/chroot/var/named/run-root/etc/named.conf

    Does that make any sense? Perhaps I should change the symbolic link in /etc the above instead?
     
  7. kturby

    kturby Guest

    0
     
    Well, I tried a symbolic link to both locations. No luck.

    Any other thoughts?
     
  8. kturby

    kturby Guest

    0
     
    Has anyone else other than the topic starter encountered this after applying the recent RHEL updates this weekend?

    As best I can tell, it looks like the update made the DNS configuration revert to the default/original (non-Plesk) configuration.

    Is there a way I can reinstall the Plesk DNS portion? I put in a ticket with Plesk support hours ago -- but they haven't been able to respond yet.

    This is impacting everyone on our server: no web, no email... nothing. I'd appreciate any ideas or suggestions.

    Thanks!
     
  9. jwdick

    jwdick Guest

    0
     
  10. kturby

    kturby Guest

    0
     
    Thanks!

    No -- I didn't see that yet; however, Plesk support did contact me last night EST and fixed most of the problem. They didn't provide the exact fix -- except to indicate that they "hard linked" two files, and rebuilt the DNS files via a script.

    There appears to be a remaining minor problem with domain aliases -- the main domains are working -- but the aliases don't.

    I've got a reply into SWsoft support -- hopefully they'll be able to help today.

    Thanks for all the help and suggestions! Our main functionality is back up this morning.
     
  11. pixoul

    pixoul Guest

    0
     
    I'm also encountering the same problem. Searching for other threads now...
     
  12. pixoul

    pixoul Guest

    0
     
    This appears to have fixed it for me (from the above-referenced thread):

     
  13. Artur

    Artur Guest

    0
     
    thanks for the solution
     
  14. billium

    billium Guest

    0
     
    May have to revert to old named script

    Hi I ran in to a bunch of problems after installing updates to bind (named), and nothing seemed to work. So I went and got an old version of named script, backed up the newer one just in case and put the old one:

    > mv /etc/sysconfig/named /etc/sysconfig/named_saved_by _me
    > vi /etc/sysconfig/named then paste the following into the file and write and quit:

    ROOTDIR="/var/named/run-root"
    OPTIONS="-c /etc/named.conf -u named"

    then try starting the named service again:

    > /etc/rc.d/init.d/named start

    if you get any messages that it cant find the config file, create a symbolic link like:

    > ln -s /etc/named.conf /var/named/chroot//etc/named.conf

    hope that helps you guys! After working on it for about 5 hours this fixed my problem.
     
Loading...