1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

New Domains - Not Authorized to View Error - HUGE Sev1 - NEED HELP!

Discussion in 'Plesk for Windows - 8.x and Older' started by esaslo, Jan 26, 2005.

  1. esaslo

    esaslo Guest

    0
     
    We just added three new domains to our plesk 7.0 administrator; each of them use ASP/SSI to go to the pages.

    Upon trying to access the pages, a login box pops up; if you cancel the login box, you get a 401:Unauthorized ("You are not authorized to view this page") Error.

    I seem to remember having this error in the past with a previous version of Plesk, and I seem to remember it having to do with something in the permissions of IIS.

    Could someone PLEASE Email me a fix-- this is HUGE. The site has been down for 48 hours already, and its costing a lot of money each hour its down.

    Thanks!

    ES

    the sites are:
    www.topcentre.com
    www.corpsport.com
     
  2. cbtrussell

    cbtrussell Guest

    0
     
    Looks like you have a permissions issue. You should try to login to your box via RDP/TS and run the Plesk Reconfigurator via the Start Menu.

    Although it should be noted this utility never seems to help me much, it may help you.

    If you are really losing that much money, it seems to me this would be a good opportunity to purchase a $75 plesk support ticket?

    Brandon
     
  3. esaslo

    esaslo Guest

    0
     
    Ticket

    I did.

    The bastards said it wasn't their problem, it was Microsoft's-- and Microsoft said it wasn't their problem, it was plesk.

    The only thing they could agree on was to "wipe the system and start from scratch"... which we both know isn't a solution.


    So i was appealing to all of your help! Cause I know you are all geniuses!


    Thanks!


    Elmer
     
  4. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    it is a permission problem, and is solved many times either from plesk control panel or from the remote desktop by applying changes to the domains and to folders. be sure to give internet users read permissions.

    I also do help to fix problems if interested.
     
  5. webbit

    webbit Guest

    0
     
    401:Unauthorized ("You are not authorized to view this page") Error

    AbsolutelyFreeW is right.
    The problem is permissions.
    I can re-produce the problem by changing the FTP password in Plesk. What happens is it seemed to change the FTP password right away but in IIS the password for default access to the site needs to match the plesk FTP password entered or you get this 401 error.

    I don't know why this password was not updated when the password in the Plesk Control Panel was updated but it sounds like a bug that someone should report to plesk.

    To fix your problem reset the username and password for the FTP access to the site to something known - this is done through the plesk control panel - under domain (Hosting Setup)

    Once you have the password and username set open the IIS manager on your server. Expand the Web Sites tab and right click on the site that is giving you trouble. Select Properties.

    Select the Directory Security tab at the top and then click the EDIT button next to Authentication and Access Control.

    Make sure the username is set in the following format (assuming your server is not in a domain)
    SERVERNAME\IUSR_WEBSITEUSERNAME

    Where SERVERNAME is your server's name and WEBSITEUSERNAME is the FTP username specified in Plesk.

    Then Type the correct password in the Password box and click OK, and Confirm the password when prompted.

    That should be it. It's also a good idea to stop and restart the particular website just to be sure.

    Give that a try ;-)
     
  6. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    webbit, but iusr and ftp user is not the same thing, by making a default user to yuor ftp user, you will give the entire world full permissions to all your files, please be aware of this distinction
     
  7. webbit

    webbit Guest

    0
     
    Yup

    I'm pretty new to Plesk for windows but I guess I was assuming that when you change the FTP passwd in the plesk control panel it also changes the password for
    IUSR_xyz, but i could be wrong. Maybe it only changes the passwd for xyz and the IUSR_xyz is a random passwd.

    IIS uses the IUSR_xyz account to allow anonomous access to your files for viewing over the web. If the password does not match to what is set in IIS then access will fail to this site.

    I know that when you add a domain 2 users are added.
    IUSR_xyz
    xyz

    I assumed they both had the same passwd but maybe not....

    Can anyone explain to me how Plesk and IIS work together in relation to passwords and these user accounts.
     
  8. Plesk Support

    Plesk Support Guest

    0
     
    Re: Ticket

    Dear Elmer,

    Thank you for the report. It is very important for us to know cases of bad service, so that we would be able to improve it.

    Please let me know the ticket number where you were serviced in such a bad way, unfortunately, I was unable to find it myself.


    --
    Eugene Tarasov
    Technical Support Department Manager
    SWsoft, Inc.
     
  9. consultorpc

    consultorpc Guest

    0
     
    I'm having the same problems on a recent Plesk 7.5.4 for Windows, have you fixed it yet ?
     
  10. AbsolutelyFreeW

    AbsolutelyFreeW Guest

    0
     
    its something that sometimes occur occasionally and is fixed by setting permissions, or in some cases check firewall settings..
     
  11. space2host

    space2host Guest

    0
     
    We are also sailing in same ....
    I dont think still it was not sorted .... We have applied patches upto date....

    Regards
    Webmaster
     
  12. Hilco

    Hilco Guest

    0
     
    Encoutered this problem as well, comes in 2 forms. Seems to be triggered when you change an FTP password in PLESK. Once you have it, it also occasionally comes back spontaneously (at least that's what's happening to me.

    1st form :I get hit with a log in box when I try to surf to the affected site. Still havent solved how to get rid of the box. Fiddling with permissions in IIS helps, but havent find a sure fire way of fixing this.

    2nd form: 404 error, restarting the site and the application pool in IIS solves this.
     
  13. ecohosting

    ecohosting Guest

    0
     
    This permissions issue is a serious flaw

    I'm sorry to be sounding alarmist here but this permissions thing is a serious problem. Why is it not being dealt with by SWSOft? I just spent countless hours building a clean new win2003 installation with a clean install of the most recent Plesk and cannot get a single website to work because of this permissions bug. If effectively renders this software useless to me.

    There is a check permission button on the domain view page but it does absolutely nothing to resolve simple access to the sites. There is also the Reconfigurator but it too has no affect on the problem. I have tried following some of the recommendations here but they too do not work for me.

    I am not about to go manually tweak the permissions of every account I create either. Plesk is a tool we all bought to avoid this kind of thing. Note the word Web Host Automation Software. Not Web Host Manual Software.

    I humbly ask the Plesk developers to fix this most serious of problems. Put together a patch or something. How about an official post on how to temporarily get around the issue until you do fix it. Something, anything would be nice.

    Sincerely, G.
     
  14. timberman_r

    timberman_r Guest

    0
     
    Me too!

    I also have sporadic passwords either expiring or not syncing between the IUSR account and IIS6

    I don't have these problems on stand alone servers.. only on the plesk servers.

    What I have to do is change the password for the IUSR account associated with that site. Then go into directory security and put the password in to sync with the password I set in User Manager.. After that everything works fine..

    I can not replicate this issue.. just happens every now and then.. and I usually don't have a lot of downtime as I monitor all websites for function.

    Russ
     
  15. ecohosting

    ecohosting Guest

    0
     
    I have yet to get one site working! I've resorted to uninstalling Plesk and managing things manually until this SERIOUS ISSUE is resolved. Hello, Is anyone from SWSoft reading this???
     
  16. ashley

    ashley Basic Pleskian

    23
    23%
    Joined:
    Nov 12, 2001
    Messages:
    27
    Likes Received:
    0
    Hi

    There is a lingering question here - does anyone know the answer for sure? That is ...

    If you set the IUSR_domainaccount to the same as the FTP password then is there a security risk?

    Or should you set FTP password in Plesk and then as timberman_r says do you need to "change the password for the IUSR account associated with that site. Then go into directory security and put the password in to sync with the password I set in User Manager"?

    Regards
    Ashley
     
  17. webbit

    webbit Guest

    0
     
    I believe this problem has been fixed in plesk 7.5.5
     
  18. PeppezZ

    PeppezZ Guest

    0
     
    PLESK 8.6 year end 2008: PROBLEM STILL NOT FIXED, this is disgustive
     
Loading...